New Redgate Installer launched - let us know what you think

As announced on our Live Stream event, we have released our new Installer. This is a complete overhaul of the installation experience, and as it takes its first steps we'd like to carry on improving it. We have already released SQL Index Manager with the initial version, and we'll be rolling out other tools and bundles progressively over the next few weeks. There are further enhancements planned such as bulk uninstallation and tie-ins with licensing, and we'd love to hear both your feedback on what we've done and what you'd like to see in future.
Tech Lead, SQL Toolbelt
Redgate Software
Tagged:

Comments

  • It's very nice, however, when run from SSMS in Windows 10, it requires an Administrator approval and fails to install. This happens even when Update & Install is run from SSMS in Administrator mode. It'd be nice to be able to save the download somewhere so it could be run in Administrator mode.
  • I find the updating of Redgate tools clunky. I shouldn't have to go into each individual tool and update it separately. I want a single "Redgate Tools Update" utility that shows the tools I have installed and allows me to update them all at the same time.
  • @kkam99518 At the moment we're releasing the new installer for single products. As soon as this rollout is done we're moving on to the full Toolbelt installers - which will show you all available updates separately from new products and allow you to do them en masse. Hopefully this will improve your experience.
    Tech Lead, SQL Toolbelt
    Redgate Software
  • zippy72zippy72 Posts: 21 Bronze 2
    Having suggested this in UserVoice, I'm glad to see you're moving towards an integrated installer. Thank you.
  • NedBushNedBush Posts: 1 New member
    Didn't work for me.

    SQL Prompt 8.2
    MSI returned failure code InstallFailure
    Service 'Redgate Client' (RedGateClient) failed to start. Verify that you have sufficient permissions to start system services.

    Old installer worked fine.
    Latest version of SQL Prompt is buggy to the point of unusability, but installer worked fine.
  • @NedBush Sorry to hear that. Are you able to manually start the Redgate Client service? This is normally the last thing that the installer does so I think if you can get the client started then you should be good to go.
    Software Engineer
    Redgate Software
  • altondaltond Posts: 1 Bronze 1
    It worked fine for me, but I wish there was a border around the central white space. It doesn't stand out as a window on my screen.
  • Hi @altond,

    Thanks for the feedback. We've added a one pixel wide black border to the window so hopefully it should stand out a bit more in the future.
    Software Engineer
    Redgate Software
  • BoCoKeithBoCoKeith Posts: 2 New member
    Worked perfectly find for me, but I have only SQL Prompt. Found the new installer intuitive and informative.
  • mattjharpermattjharper Posts: 4 New member
    edited October 25, 2017 8:53AM
    Previous version just worked when I ran as admin. With the new installer I had to:
    1. run the exe from command line (as admin) with Extract option to get the MSI files
    2. run the msi using msiexec from command line (as admin)
    I appreciate the problems are probably caused by our group policy, but the previous version was a lot easier for me! (Especially if there are multiple updates) Going forward I guess I now know the steps I need to take - but working this out this morning took a while! (definitely going to have to turn frequent updates off)

    Thanks.
  • TechTnTTechTnT Posts: 1 New member
    Not sure if it is installer related or what; however, there seems to be a recurring issue popping up with the inability to install a SQL Search 3 due to the inability to fully uninstall previous versions in the scenario when SSMS was updated. I had to manually purge the registry of all references to "SQL Search" in order to fully remove SQL Search from the installed programs listing.
  • timberzentimberzen Posts: 3 New member
    1 item could not be installed
    * SQL Search 3.0
    MSI returned failure code InstallTempUnwritable
    ---
    Which is pretty disapointing really.
    Your software has the tick box grayed out so you cannot repair/reinstall software when it thinks it is still in the system, even if you used the "MicrosoftProgram_Install_and_Uninstall.meta.diagcab" tool to remove it, when uninstall/Remove does not work. Your tooling for Adding and Removing features sucks (possible poor QA or fragile software or poor UX). If you install your aoftware one and never again that might be the wises move. If you try and keep it uptodate, that you are bound for trouble, if you mix and match features, eg buy one ToolBelt and One DevTool and use bits of both, and activate using your email id, then you are in for a whole world of pain sadly. A feature of red-gate tools is that you depend upon it and it will break at the most inconveinent point possible. So dont depend upon it for critical systems (unless you install once and never change it).
    Red-Gate really needs to invest in QA engineers.
  • timberzentimberzen Posts: 3 New member
    4esy5ksna6xj.png
    Unable to upgrade SQL compare MSI returned failure code InstallTempUnwritable
  • zippy72zippy72 Posts: 21 Bronze 2
    I think the installer is heading in the right direction, and it's early days, but I would agree that I have seen a few unnecessary bugs creep into RedGate products recently.
  • The next issue we're working on is bulk uninstallation of our products - this comes up a lot in feedback as a particularly painful experience for people who install the whole toolbelt. SQL Doc is in the process of releasing with an integrated uninstaller right now, and it will roll out across the suite in the coming days.
    Tech Lead, SQL Toolbelt
    Redgate Software
  • wlappinwlappin Posts: 1 New member
    Doesn't seem like I can install anything with the new installer:
    e3l6aajy14er.png
    mntjcbfqmky8.png
  • I get "MSI returned failure code InstallAlreadyRunning" from all the installers in the toolkit, so I currently cannot install my licensed products. This is a total failure, and was triggered 100% definitely without any previous installers running, so it looks like the current version deserves compensation to your clients for being totally unusable. Please fix a.s.a.p.
  • cdebel2005cdebel2005 Posts: 2 New member
    We had SQL Compare v10 on this computer. We removed the licence, uninstalled the product, then installed SQL Compare v13.1 or at least, Tried...

    It keep telling us that we don't have sufficient privileges. (It seems to be stuck on RedGate Client service).

    We are admin, and we run the installer by right-clicking on the file, and chose "RUN AS ADMIN"... can't see what we are doing wrong.

    03nyxif25ukc.png
    • Tried to update within the app (with v10 licence removed), it gave me the privileges error
    • Tried to deactivate the antivirus, no changes
    • Tried the full install instead of the update, no changes
    • Tried to run the full install from a command prompt ran as an administrator, no changes

    Rebooting between each step doesn't help.

    Any idea what we can do to install it? We are not using a trial, we have paid our licence. It's a serious pain in the ass! Paid 500$ for it and spending hour$$$$ trying to install it. Not funny.
  • Agree with many others who have asked for the same thing over the years--one upgrade installer for all tools, with a weekly release cycle would go a long way to "version compliance" in my view. It's a bit of a pain now. A system tray notification when upgrades/updates are available is also better than the current bar which appears. I'm in these tools every day. But when I'm opening them, it's almost always because I need to use the tool immediately. So that bar sits there blocking part of my information. If the bar pushed the screen contents down (or appeared in an existing empty area) it would be much better.

    My $0.02.
  • EdvardEdvard Posts: 1 New member
    I use the installer for a single license on SQL prompt. It works as expected and totally trouble free.
  • derVampirderVampir Posts: 3 New member
    I just used the installer for an update installation of SQL Toolbelt except SQL Monitor and SQL Backup (as these reside on the server). Had not done updates for about three months, all tools were updated in the process. Worked like a charm. Good job imho.
    One feature I'd suggest: A pure update process where the installer does not try to install tools that are not on the machine (in my case, Monitor and Backup). You can of course unselect them but still.
  • Is there a multi-tool installer out yet? Just manually launched updates for all my products and it was tedious having to do it one at a time.
    Dave Bennett
  • cdebel2005cdebel2005 Posts: 2 New member
    I hope it will help someone...
    I had tons of exchanges with Matt from Red-Gate tech support, and we have found the solution to my problem.

    RedGateClient (the licencing program) was trying to listen on some port of 127.0.0.1. But our server was not listening. If you want to know if your IP is in the listen list, from the command prompt:
    netsh http show iplisten
    

    if it's not there:
    netsh http add iplisten 127.0.0.1
    

    Once you have done that, if there was previous failed installation, delete this folder (or just rename it if you want):
    %ProgramFiles(x86)%\Common Files\Red Gate\Shared Client
    

    Try to install again and the "Verify if you have sufficient privileges to start system services" should be gone.
  • road11road11 Posts: 0 New member
    I installed it to Visual Studio 2017. Twice, I got a message from Visual Studio saying that an installation did not function properly and that I needed to reinstall or repair Visual Studio.
  • road11road11 Posts: 0 New member
    I installed it to Visual Studio 2017. Twice, I got a message from Visual Studio saying that an installation did not function properly and that I needed to reinstall or repair Visual Studio.
  • LiveCodeLiveCode Posts: 1 New member
    I am not pleased. Due to an installation problem it will not allow to reinstall as it says its currently installed. No repair option.
    You had previous versions available as downloadable zips, the page is there but the option is gone.
    Or the one link i did find allows a downloader for 8.2 then trys to install 10 anyway, but stops because it says 10 already installed, so 8.2 never was going to be installed. A bait n switch.

    I have used and liked very much 8.2, and in the old coke/ new coke theme, I don't want to upgrade as it did what I wanted and I am comfortable and productive with it.
    I don't like being told "well you're gonna like this..." or "forced to upgrade" because it's better for someone else's plan.
    I don't require on-going for support for 8.2, other than to get it back installed.
    I would ask for a stand alone release be available so I can fix this if it ever happens again, when-ever where-ever so I don't have to wait for tech support to be available (weekends, 2:45am, holidays, whenever I have time to code and need my tools working now).

    It worked just fine on the machine I had it on, and new versions "often" require upgraded machines to offer the same previous performance, and..... just offer the previous versions and let the user upgrade when they're ready. When I'm ready for bigger/ faster, I know where to find you.
Sign In or Register to comment.