What are the challenges you face when working across database platforms? Take the survey
Options

Should not compare unmapped tables

I am using SQL Data Compare 12.4.10.4968
My goal is to copy the 477 rows of one table from an Azure database to a local database.
My local database contains only one table - Azure contains 82 tables, some with 100Ks rows.
My project shows only the one table mapped.
When I run the compare, it goes through each and every table in the source database. The results panel then shows all of the tables, with 81 unmapped at the top and my one mapped table at the bottom. Of course, they're all selected for synchronization (what happened to the empty box at the top to unselect all?)

I tried setting "Use checksum comparison" hoping that might help but no joy.

I don't use these tools very frequently - is this new behavior? It makes the tool much less attractive (10 minute wait for comparing tables with no destination).

Best,
Scott
Tagged:

Comments

  • Options
    Hello Scott,

    It sounds like you are switching to the Tables and Views tab on the edit project dialog, which allows you to override the default choice of tables and views to compare. If you only want to consider data on the table that Data Compare has mapped by default, you should click "Compare Now" button at the bottom of the screen.

    Unfortunately Azure comparisons tend to be a little slower than connecting locally or over a LAN. SQL Data Compare only reads the individual rows of tables that have been mapped, but it does gather the schema of every table. 7 seconds per table sounds unusually slow, unless each table has hundreds of columns, constraints or indexes.

    One workaround that some of our customers have used is to connect as a user that cannot see the majority of the tables on the database. However, this is normally only needed for databases with thousands of tables.
    Software Developer
    Redgate Software
Sign In or Register to comment.