What are the challenges you face when working across database platforms? Take the survey
Options

SqlSourceControlPackage failing to start SSMS

diegostamignidiegostamigni Posts: 2 Bronze 2
edited August 11, 2017 4:32PM in SQL Source Control
Hi fellas,
I have a problem running SSMS 17.2 and SqlSource 5. After installing the SQL Toolbet suite, I can't start SSMS (see error attached). In the log is pretty clear that the problem is related to SqlSourceControlPackage (search for it) infact, if I uninstall it (just SQL Source) everything returns back to normal, and I can start SSMS without any problem.

bp352l27hy21.png
im212vyy9p4l.png

On a side note: I'm running Windows 10 Pro, SSMS 17.2 and SQL Server 2016 and I've already trying to reinstall SSMS and the SQL Source in different combinations without any positive result.
Tagged:

Comments

  • Options
    TL;DR I was able to solve the problem above by just simply reset the window layout.

    If you're encoring in the same problem, try to (suggested by the Redgate support team):
    - Start SSMS
    - Reset the window layout by going to Window -> Reset layout -> Yes

    If this solution still doesn't work, try to (this is the solution that actually worked for me, based on the above):
    - Start SSMS
    - Close the SQL Source tab
    - Close any other panel open (like the Object explorer)
    - Restart SSMS
Sign In or Register to comment.