Database Restore with Filestream fails

I have a Very large database, 242GB that contains a filestream that is about 160GB of that total space.
I can run a full backup and it completes with no errors, but when I try to restore the database it get to about 50% and fails with the following error.

Thread 22 error:
Failed to service command. Error code: -2139684860
Process terminated unexpectedly. Error code: -2139684860 (An abort request is preventing anything except termination actions.)

SQL error 3013: RESTORE DATABASE is terminating abnormally.
SQL error 3634: The operating system returned the error '32(The process cannot access the file because it is being used by another process.)'
while attempting 'OpenFile' on

SQL Backup exit code: 790
SQL error code: 3634

I have tried this several times, and it always fails around 50% but always on a different file.
There is no Anti virus running on this and I have made sure it is to a new clean folder.
I have also tried to create the DB first and then restore into that, but it fails the same way.

Any assistance is appreciated.

Thank you.
Sign In or Register to comment.