VDI error 1000: Failed to recognize the SQL Server instance

keymookeymoo Posts: 38
edited December 3, 2008 3:18AM in SQL Backup Previous Versions
Hi there,

I have a SQL Server 2000 SP3 machine running on Windows 2000 Server SP4. I get the following errors in the SQL Backup log:
SQL Backup log file 5.3.0.178

-SQL "BACKUP LOGS EXCLUDE 'master, msdb, model' TO DISK = '\\BACKUPSERVER1\SQLbackups\Monday\SQLSERVER1\<database>\<AUTO>.sqb' WITH COMPRESSION = 2, ERASEFILES = 2, THREADCOUNT = 2 "

-----------------------------  ERRORS AND WARNINGS -----------------------------


01.12.2008 16:02:38: Backing up MY_CRM_DATABASE (transaction log) to: 
01.12.2008 16:02:38:   \\BACKUPSERVER1\SQLbackups\Monday\SQLSERVER1\MY_CRM_DATABASE\LOG_(local)_MY_CRM_DATABASE_20081201_160238.sqb

01.12.2008 16:02:40: VDI error 1000: Failed to recognize the SQL Server instance name.  Check that the SQL Backup service startup user has read/write rights to access the SQL Server service information.  You can do this by using the "sc sdshow/sc sdset" commands.
01.12.2008 16:02:40: 
01.12.2008 16:02:40: Memory profile
01.12.2008 16:02:40: Type             Maximum     Minimum     Average     Blk count   Total      
01.12.2008 16:02:40: ---------------- ----------- ----------- ----------- ----------- -----------
01.12.2008 16:02:40: Commit           891027456   4096        1136460     1504        1709236224 
01.12.2008 16:02:40: Reserve          51118080    4096        1068199     196         209367040  
01.12.2008 16:02:40: Free             66588672    4096        479695      477         228814848  
01.12.2008 16:02:40: Private          891027456   4096        2171561     860         1867542528 
01.12.2008 16:02:40: Mapped           1019904     4096        116914      46          5378048    
01.12.2008 16:02:40: Image            5808128     4096        57534       794         45682688   
01.12.2008 16:02:40: 
01.12.2008 16:02:40: Warning 300: Backup failed.  Retry attempt: 1
01.12.2008 16:02:44: VDI error 1000: Failed to recognize the SQL Server instance name.  Check that the SQL Backup service startup user has read/write rights to access the SQL Server service information.  You can do this by using the "sc sdshow/sc sdset" commands.
01.12.2008 16:02:44: 
01.12.2008 16:02:44: Memory profile
01.12.2008 16:02:44: Type             Maximum     Minimum     Average     Blk count   Total      
01.12.2008 16:02:44: ---------------- ----------- ----------- ----------- ----------- -----------
01.12.2008 16:02:44: Commit           891027456   4096        1136460     1504        1709236224 
01.12.2008 16:02:44: Reserve          51118080    4096        1068199     196         209367040  
01.12.2008 16:02:44: Free             66588672    4096        479695      477         228814848  
01.12.2008 16:02:44: Private          891027456   4096        2171561     860         1867542528 
01.12.2008 16:02:44: Mapped           1019904     4096        116914      46          5378048    
01.12.2008 16:02:44: Image            5808128     4096        57534       794         45682688   
01.12.2008 16:02:44: 
01.12.2008 16:02:44: Warning 300: Backup failed.  Retry attempt: 2
01.12.2008 16:02:48: VDI error 1000: Failed to recognize the SQL Server instance name.  Check that the SQL Backup service startup user has read/write rights to access the SQL Server service information.  You can do this by using the "sc sdshow/sc sdset" commands.
01.12.2008 16:02:48: 
01.12.2008 16:02:48: Memory profile
01.12.2008 16:02:48: Type             Maximum     Minimum     Average     Blk count   Total      
01.12.2008 16:02:48: ---------------- ----------- ----------- ----------- ----------- -----------
01.12.2008 16:02:48: Commit           891027456   4096        1136460     1504        1709236224 
01.12.2008 16:02:48: Reserve          51118080    4096        1068199     196         209367040  
01.12.2008 16:02:48: Free             66588672    4096        479695      477         228814848  
01.12.2008 16:02:48: Private          891027456   4096        2171561     860         1867542528 
01.12.2008 16:02:48: Mapped           1019904     4096        116914      46          5378048    
01.12.2008 16:02:48: Image            5808128     4096        57534       794         45682688   
01.12.2008 16:02:48: 
01.12.2008 16:02:48: Warning 300: Backup failed.  Retry attempt: 3
01.12.2008 16:02:52: VDI error 1000: Failed to recognize the SQL Server instance name.  Check that the SQL Backup service startup user has read/write rights to access the SQL Server service information.  You can do this by using the "sc sdshow/sc sdset" commands.
01.12.2008 16:02:52: 
01.12.2008 16:02:52: Memory profile
01.12.2008 16:02:52: Type             Maximum     Minimum     Average     Blk count   Total      
01.12.2008 16:02:52: ---------------- ----------- ----------- ----------- ----------- -----------
01.12.2008 16:02:52: Commit           891027456   4096        1136460     1504        1709236224 
01.12.2008 16:02:52: Reserve          51118080    4096        1068199     196         209367040  
01.12.2008 16:02:52: Free             66588672    4096        479695      477         228814848  
01.12.2008 16:02:52: Private          891027456   4096        2171561     860         1867542528 
01.12.2008 16:02:52: Mapped           1019904     4096        116914      46          5378048    
01.12.2008 16:02:52: Image            5808128     4096        57534       794         45682688   
01.12.2008 16:02:52: 
01.12.2008 16:02:52: Warning 300: Backup failed.  Retry attempt: 4
01.12.2008 16:02:56: VDI error 1000: Failed to recognize the SQL Server instance name.  Check that the SQL Backup service startup user has read/write rights to access the SQL Server service information.  You can do this by using the "sc sdshow/sc sdset" commands.
01.12.2008 16:02:56: 
01.12.2008 16:02:56: Memory profile
01.12.2008 16:02:56: Type             Maximum     Minimum     Average     Blk count   Total      
01.12.2008 16:02:56: ---------------- ----------- ----------- ----------- ----------- -----------
01.12.2008 16:02:56: Commit           891027456   4096        1136460     1504        1709236224 
01.12.2008 16:02:56: Reserve          51118080    4096        1068199     196         209367040  
01.12.2008 16:02:56: Free             66588672    4096        479695      477         228814848  
01.12.2008 16:02:56: Private          891027456   4096        2171561     860         1867542528 
01.12.2008 16:02:56: Mapped           1019904     4096        116914      46          5378048    
01.12.2008 16:02:56: Image            5808128     4096        57534       794         45682688   
01.12.2008 16:02:56: 
In the registry I have set the SkipChecks key to 1 even though the SQLAgent account name is less than 30 chars. The SQL Backup Agent service is a sysadmin on the SQL Server and I have changed the format of the account to [email protected] in the services.msc applet.

What else can I try?

Comments

  • Just to add, I ran:
    sc sdshow "SQL Backup Agent"
    
    on the server and got this output:
    [SC] OpenService FAILED 1060:
    
    The specified service does not exist as an installed service.
    
    However when I run
    net start "SQL Backup Agent"
    
    I get:
    The requested service has already been started.
    More help is available by typing NET HELPMSG 2182.
    
  • In the first example, you need to use the internal name (listed as "ServiceName"), so you would run:
    sc sdshow "SqlBackupAgent"
    

    A couple of questions:
    - Are there other instances on the same machine, and what version of SQL Server are they.
    - What account is the SQL Backup Agent account running as?

    Jason
  • Thanks Jason, when running
    sc sdshow "SqlBackupAgent"
    
    I get
    D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
    

    To answer your other questions
    - There is only one default instance of SQL Server (2000 SP3)
    - The SQL Backup Agent is running as a domain account called sa-SQLBackup and is in sysadmin server role in SQL Server. It is a normal account on the server (i.e. not a local admin).
  • keymoo wrote:
    Thanks Jason, when running
    sc sdshow "SqlBackupAgent"
    
    I get
    D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)
    

    To answer your other questions
    - There is only one default instance of SQL Server (2000 SP3)
    - The SQL Backup Agent is running as a domain account called sa-SQLBackup and is in sysadmin server role in SQL Server. It is a normal account on the server (i.e. not a local admin).

    Just make it local admin and that will fix everything.
  • brosato wrote:
    Just make it local admin and that will fix everything.
    Very funny - actually I did do that just as a test and I got identical behaviour.
  • keymoo wrote:
    brosato wrote:
    Just make it local admin and that will fix everything.
    Very funny - actually I did do that just as a test and I got identical behaviour.


    I wasn't trying to be funny actually. That's what I had to do to get it working. Although I have another server that's set up identical and it works without being local admin.
  • keymoo wrote:
    brosato wrote:
    Just make it local admin and that will fix everything.
    Very funny - actually I did do that just as a test and I got identical behaviour.


    Oh, make sure you restart the service after adding the account to local admin.
  • Great that fixed it - however I really don't want to run the SQL Backup service as a local admin.

    red-gate: anything else for me to try?
  • peteypetey Posts: 2,358 New member
    This issue is usually caused by security restrictions on the SQL Server service object. When you run sc sdshow, you should run it against the SQL Server service, not the SQL Backup Agent service. That should tell you the rights that have been assigned to the service.

    Alternatively, you can download this app to check the DACL of the service.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
Sign In or Register to comment.