SQLCompare Aborting

Pete1Pete1 Posts: 5
edited December 1, 2008 7:32PM in SQL Compare Previous Versions
When you click the Compare Now button, the first step is Registering Databases.

I get the message :-
XXXX.YYYY-Reading object text
(I have substituted XXXX and YYYY for my names. The word "text" is hard to read.)

Down the bottom of the dialog :-
Index was outside the bounds of the array

When I run the compare with the two databases switched around, the compare seems to run successfully until it reaches the database that has a problem - then I get the same error as above.

Is there a problem with my first database? What can I tinker with to make this work?

Comments

  • It sounds like the problem some people have found with the new object decryption functionality. Try turning off the option 'Decrypt encrypted objects on 2005 and 2008 databases' and see if that fixes the problem.

    If that does turn out to be your problem, email [email protected] and they'll keep you up to date with the fix progress for this bug.
    Software Developer
    Redgate Software
  • Thanks for that tip.
    When I turned off that option the data compare worked.
Sign In or Register to comment.