After adding VMWare host, no host metrics are displayed and all servers show "connection failed"

MckMurrayMckMurray Posts: 36 Bronze 3
I've been running SQL monitor for a while now to monitor a handful of my servers which are VMs.

With the new VM host monitoring feature, I thought I could simply connect to my vcenter in order to start seeing host metrics for my servers, but after connecting I don't see any host metrics, and all my servers show a "connection failed" error in the Monitored Servers list. The log file shows the message: "An item with the same key has already been added."

Note that the simple VM-level monitoring seems to be still ticking along, the issue is the VM Host monitoring doesn't seem to work. Perhaps because the servers were already being monitored.

Anybody else run into this?
Tagged:

Comments

  • Russell DRussell D Posts: 1,300 Diamond 5
    Hi @MckMurray , this is a bug of sorts (though whether its a VMWare bug or a SQL Monitor bug we're not entirely sure!).

    VMWare actually throws out duplicate counters and so we have issues when trying to insert them into a database. We've fixed it in 7.0.14 which will be going out hopefully tomorrow. I'll update you when I have a definite date.
    Have you visited our Help Centre?
  • MckMurrayMckMurray Posts: 36 Bronze 3
    Thanks Russell, I just updated and 7.0.14 does resolve the issue. Thanks.
  • sheldonhullsheldonhull Posts: 33 Silver 1
    I had the same connection failed issue. I will try the update and see if this resolves my connectivity issue
  • sheldonhullsheldonhull Posts: 33 Silver 1
    I just updated to 7.0.14.8072 and am getting "unreachable" when putting in the server ip + port with credentials. I tried with, and without port number. I also tried domain\user as well as [email protected] schemes and no results.
    The log file shows:

    RedGate.Response.Engine.Monitoring.Core.Communicators.VMware.VMwarePerformanceSource - VMware server is unreachable
    System.Net.WebException: The request failed with HTTP status 404: Not Found.
    
Sign In or Register to comment.