DLM Dashboard no longer sending Drift Notification Emails

CoopsCoops Posts: 7 New member
Hi,
Our installation of DLM Dashboard appears to have stopped sending drift notifications. We can still get "Email Settings Test" and "Email Notification Change" emails, just not drift notification emails. This is using DLM Dashboard 1.7.6.1576. Settings are "Whenever any database changes schema", and we can see drift in the web dashboard. We have tried restarting the DLM services but have seen no improvement.
Tagged:

Comments

  • tcpmotcpmo Posts: 3 Bronze 1
    Ditto, Similar setup and the exact same symptoms.
  • Jessica RJessica R Posts: 1,319 Rose Gold 4
    Hi @Coops and @tcpmo, so sorry to hear you're both running into issues with this!

    Just to confirm-
    - Is this happening with any email address that you send to?
    - When did this stop working for you both?
    - What SMTP server are you using? Is there anything in your outbox?
    - If you go to C:\ProgramData\Red Gate\Logs\DLM Dashboard and open your latest "RedGate.SQLLighthouse.SQLServerMonitoringService-xxxx.log" files, do you see any events containing "Starting SendEmailOnConfigChange"? Are there any errors after those events?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • tcpmotcpmo Posts: 3 Bronze 1
    @Jessica R - Seems to have had fixed itself after a restart but has stopped again. As you can see the last notification happened on the 14th of September even though we have had changes after.

    PS C:\ProgramData\Red Gate\Logs\DLM Dashboard> Get-ChildItem -recurse | Get-Content | Select-String -pattern "Email"
    2017-08-23 12:31:43.674 +08:00 [Debug] Successfully queued "email (subject: DRIFT: Cue (Production))"
    2017-08-23 12:31:44.017 +08:00 [Debug] "email (subject: DRIFT: Cue (Production))" successfully sent.
    2017-08-24 21:51:51.390 +08:00 [Debug] Successfully queued "email (subject: DRIFT: CuePOS (Production))"
    2017-08-24 21:51:51.453 +08:00 [Debug] "email (subject: DRIFT: CuePOS (Production))" successfully sent.
    2017-08-29 17:32:37.311 +08:00 [Debug] Successfully queued "email (subject: Email notifications confirmation)"
    2017-08-29 17:32:37.311 +08:00 [Information] New email configuration applied: "Sending email from
    '[email protected]' to '[email protected]' via mail.backupservers.us:25"
    2017-08-29 17:32:37.389 +08:00 [Debug] "email (subject: Email notifications confirmation)" successfully sent.
    2017-09-07 13:01:23.234 +08:00 [Debug] Successfully queued "email (subject: DRIFT: CuePOS (Production))"
    2017-09-07 13:01:23.359 +08:00 [Debug] "email (subject: DRIFT: CuePOS (Production))" successfully sent.
    2017-09-07 16:15:46.144 +08:00 [Debug] Successfully queued "email (subject: DRIFT: CuePOS (Production))"
    2017-09-07 16:15:46.253 +08:00 [Debug] "email (subject: DRIFT: CuePOS (Production))" successfully sent.
    2017-09-11 10:30:17.584 +08:00 [Debug] Successfully queued "email (subject: DRIFT: InfinityStaging (Development))"
    2017-09-11 10:30:17.663 +08:00 [Debug] "email (subject: DRIFT: InfinityStaging (Development))" successfully sent.
    2017-09-11 17:42:09.774 +08:00 [Debug] Successfully queued "email (subject: DRIFT: CuePOS (Production))"
    2017-09-11 17:42:09.852 +08:00 [Debug] "email (subject: DRIFT: CuePOS (Production))" successfully sent.
    2017-09-11 18:20:21.808 +08:00 [Debug] Successfully queued "email (subject: DRIFT: Cue (Production))"
    2017-09-11 18:20:21.870 +08:00 [Debug] "email (subject: DRIFT: Cue (Production))" successfully sent.
    2017-09-14 14:33:35.969 +08:00 [Debug] Successfully queued "email (subject: DRIFT: Cue (Production))"
    2017-09-14 14:33:36.125 +08:00 [Debug] "email (subject: DRIFT: Cue (Production))" successfully sent.
  • Jessica RJessica R Posts: 1,319 Rose Gold 4
    Thanks @tcpmo!

    Hm, have you by any chance changed the time to wait before sending emails? (as described here: http://documentation.red-gate.com/display/DDB1/Combining+changes+into+one+email+notification)

    Do you ever find the DLM Dashboard Monitoring Service not running?

    Can you please zip up all the log files and send them to [email protected]?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • tcpmotcpmo Posts: 3 Bronze 1
    UserSettings.config - No such file exists.

    Three services are running without interruption.

    Have sent the log files via email.

  • Jessica RJessica R Posts: 1,319 Rose Gold 4
    Hi @tcpmo!

    Just in case you hadn't received my email reply on this, I've copied it below:

    I don't see any issues in there that would explain why the emails aren't sending, they unfortunately just appear to not send.

    In case something is corrupted with the install, can you please uninstall DLM Dashboard and then reinstall from here: ftp://support.red-gate.com/patches/DLMDashboard/19Aug2016/DLMDashboard.exe

    (All data is stored in a RavenDB database in c:\ProgramData\Red Gate\SQL Lighthouse which persists after an (un/re)install, so this won't erase your history.)

    Can you please then test a change to see if an email sends?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


Sign In or Register to comment.