What are the challenges you face when working across database platforms? Take the survey
Options

Bug: Refresh suggestions does not include new columns.

ofredeofrede Posts: 11 Bronze 1
edited June 21, 2017 11:50AM in SQL Prompt
When adding or removing a column to a table and pressing CTRL+SHIFT+D (Refresh Suggestions), Sql Prompt no longer updates correct.

If I write SELECT * FROM <myNewlyUpdatedTable> and press the TAB-key on the asterix, I only get the old columns (after having added a new column and then refreshed suggestions).

Also if I remove a column from a table and refresh suggestions and then press the TAB-key on the asterix, I would expect the newly removed column to not show up, but it does.

I have to close my SQL Server Management Studio and restart it in order to have my columns refreshed.

<Edit:> Using Version 8.0.4.1638 on SQL Server 2012.</ Edit>
Tagged:

Comments

  • Options
    Hi ofrede,

    Thanks for your feedback, sorry to hear that Refresh Suggestions is not working well for you

    I've tried the following cases on my local instance of SSMS 2014 and couldn't reproduce the issue.

    1. Creating a new table with one column - autocomplete works
    2. Adding a second column and refreshing suggestions - autocomplete works
    3. Remove that second column from the table and refreshing suggestions - autocomplete works

    When you refresh suggestions, do you see the SQL Prompt loading popup in the bottom right?

    al24b2c2myej.png

    Best,
    Michael
    Michael Clark
    Technical Lead, SQL Monitor
  • Options
    Keith_JKeith_J Posts: 1 New member
    I've got the same issue.

    My local setup:
    SQL Server Management Studio 15.0.18338.0
    SQL Server Management Objects (SMO) 16.100.41011.9
    Microsoft Analysis Services Client Tools 15.0.19205.0
    Microsoft Data Access Components (MDAC) 10.0.19041.1
    Microsoft MSXML 3.0 6.0 
    Microsoft .NET Framework 4.0.30319.42000
    Operating System 10.0.19041
  • Options
    ofredeofrede Posts: 11 Bronze 1
    Keith_J,

    I recall that I had the problem on a database on a server, which was a copy of another database on the same server.

    Basically I had backed up a database on server and restored it with another name on the same server.

    Is that the same issue? Because if it is, it might give Red-gate a hint about what the problem is.

    I never got the problem solved - but the problem only exists on the one, copied/restored db.
Sign In or Register to comment.