Compare msdb live to backup file fails

johnc650johnc650 Posts: 16
I took a backup file of my MSDB db from a few days ago and tried to compare with the live database. When it tries to retrieve the schema it fails with the message, "String was not recognized as a valid date time".

I tried both my red-gate sql backup file and my native sql backup file.. both do the same thing.



  • Hi John,

    What happens if you try to compare your msdb database to itself?

    Does this succeed or fail with the same message?

    Would it be possible for you to send the SQL Backup backup file to [email protected] quoting reference number F0017400 in the subject?

    Matthew Flatt
    Redgate Foundry
  • Sorry for the delay in this response.

    The issue seems to be a bug with the SQL Compare (and Data Compare) backup reader.

    I can recreate your symptoms on my test servers with any version of my msbd databases.

    The problem means that you cannot compare any backup of the msdb database.

    I have informed the development team about this. For your reference the bug tracking code for this issue is: SC-4179.
  • I just wanted to update you with regards to this issue.

    It is currently scheduled to be fixed in SQL Compare 8.0, which should be available Q1 2009.
  • raoulteeuwenraoulteeuwen Posts: 7
    edited June 4, 2009 4:24AM
    Hi. Just installed the RedGate tool set and trying to get it to work. I'm trying to compare 2 databases (1 on a 2000 server, 1 on a 2005-server). I'v connected to the 2 servers where the databases reside, picked a few tables (to test the tools), configured the key fields in each table (wish there was an easier option for that: do i really need to tell Data Compare for each table what the key field(s) is (are)?).

    When i press compare, i get a green tag next to Registering databases and Mapping, but when at 'Comparing databases', i get "Exception throw by db reader 2".

    In my case msdb is not involved (or am i missing something :-)?), so is my error message similar/related to this thread and do i have to wait for Data Compare 8, and if so, what causes this error?

    Or is there another reason i'm getting this error-message? I've searched for the error, but could not find any other related message on the forum.

    (Update: just found ... wledgebase\SQL_Data_Compare\KB200903000364.htm . I'm using version 7. But i am simply selecting tables to compare. I'm not adding where-clauses.)

  • This error doesn't sound related to this thread.

    Normally 'error in db reader' means that there is an invalid query being submitted, usually caused by an invalid WHERE clause filter.

    Can you check any WHERE clauses you have configured in your SQL Data Compare project?

    If this doesn't help, can you create a new forum thread, or if you want to raise a ticket, send an email to [email protected].

    I hope this helps.
  • Thank you VERY much for this SUPER fast reply Chris!

    I've created a new topic: ... 2602#32602 . I'm (afaik) not using any where-clause.

    Posting it on the forum makes the info more available for others? But if i get a faster/better reply by emailing support, please let me know, then i will use that email box!
Sign In or Register to comment.