Unable to profile IIS Express when using SSL and custom port

Hi, sorry for the newbie question. I am trying to profile my site but I cannot see it in the list under IIS Express. I then tried to point the session details to where it is hosting (and running) on IIS Express which is https://localhost:44388 but I cannot seem to get Profiler to connect or recognise the url. Any tips / documents in place for this scenario?
Paul.
Tagged:

Comments

  • Jessica RJessica R Posts: 1,031 Rose Gold 3
    Hi and thanks for your post!

    ANTS gets the list of sites that you can choose to profile by checking for which sites are already configured in IIS Express. It checks this from your IIS Express applicationhost.config file in %userprofile%\Documents\IISExpress\config.

    if you launch your site from Visual Studio though, then VS will create a separate "applicationHost.config" file for the project that it uses to run your application and ANTS doesn't pick up on this.

    Normally, you could use the "Profile an application not shown in this list" option and point ANTS to the location of the site you need to profile, but you can't set the SSL option from here.

    With that, what you could do to profile the site with SSL:
    • Rename the c:\users\username\Documents\IISExpress\config\applicationhost.config file
    • Locate the VS-created applicationhost.config file (usually in the path like C:\Users\username\Documents\Visual Studio 2015\Projects\WebSite5\.vs\config)
    • Copy and paste it into the config file in %userprofile%\Documents\IISExpress\config
    • Start the profiler and choose your site (Note: Make sure to stop any current IIS Express process running on port 44388 to make sure ANTS can use it to start the site)

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


Sign In or Register to comment.