What are the challenges you face when working across database platforms? Take the survey
Options

Invalid name character in network library?

MikeKMikeK Posts: 5 New member
Hi,

I've inherited a database recently, and every time I try to edit any of the objects in the database, when I go to close or move focus away from the editor window (say to the object explorer), I get this error dialog popping up:

ll8zbbnm7ql1.png

If I turn off suggestions in SQL Prompt - the problem goes away. Does anyone have any idea as to what the cause might be so that I can change the offending item? The name of the database is multi-part (e.g. [MyCompany.ApplicationName]), but there's definitely no spaces anywhere. I'm connected to the database with Windows auth.

Thanks,

Mike.
Tagged:

Comments

  • Options
    MikeKMikeK Posts: 5 New member
    SQL Prompt version I'm using is 8.0.0.1241, connecting to SQL Server 2016
  • Options
    James RJames R Posts: 104 Silver 4
    Hi @MikeK,

    Thanks for your post! As you've noticed this is similar to an issue with whitespace in 'workspaceID' (https://forum.red-gate.com/discussion/80957/error-dialog-when-using-ssms-invalid-name-character-in-workstation-id#latest). We're looking into it but haven't managed to reproduce it locally yet.

    To help us reproduce the issue, do you use any Additional Connection Parameters when connecting to your server? If so, what is the value of those parameters?

    I'll update here if we have any progress :)

    Thanks,
    Software Engineer
    Redgate Software
  • Options
    MikeKMikeK Posts: 5 New member
    Hi @James R

    You got me thinking there about the connection parameters. I usually connect using Windows auth, but I just changed it over to using a SQL login to see if that helps, and I'm now not getting the error dialog.

    My AD account is [DOMAIN\firstname surname], so is it possible that having a space in my Windows login is the cause?

    Although saying that, the database(s) I got that error on was on a development server. But when I connect to my local SQL instance also by Windows auth (same login), I have no issues. Just a thought.

    Thanks,

    Mike.
  • Options
    MikeKMikeK Posts: 5 New member
    Just to add to that, I didn't change any other connection parameters - I literally changed the authentication type over from Windows to SQL and left everything else as it was. Both login types are sysadmin on the server.
Sign In or Register to comment.