What are the challenges you face when working across database platforms? Take the survey
Options

Remote sql server connection

mltgamesmltgames Posts: 17 Bronze 1
edited May 18, 2017 12:43AM in SmartAssembly
I had sql server running, locally everything is working.

I want to connect another pc that will share my map folder and sql server.

My map folder is working perfectly on both pc except i cant connect to sql server on the remote pc.

I openned port 1433 for the sql server.

But doesnt work.

I tried to connect to the remote server using smss and it work. (I provided the ip, login and password)

Is smart assembly support tcp/ip connection for sql server on port 1433? If i disable shared memory access on the sql server, smart assembly doesnt run locally, it look like it work only using shared memory instead of tcp/ip

Is there any connection string to specify/force to use tcp/ip?
Tagged:

Comments

  • Options
    mltgamesmltgames Posts: 17 Bronze 1
    I added 1433 to my connection string and it work.

    Here is my config if it can help someone.


    <SmartAssembly.Settings>
    <Options>
    <Database ConnectionString="Data Source=192.168.0.8\SmartAssembly,1433; Initial Catalog=smartassembly; User Id=sa; Password=password" DatabaseEngine="1" LastProject="{ae726256-376b-4c6a-80f4-505fef2a73cf}" MasterConnectionString="Data Source=192.168.0.8\SmartAssembly,1433; Initial Catalog=master; User Id=sa; Password=password" Server="192.168.0.8\SmartAssembly,1433" />
    </Options>
    </SmartAssembly.Settings>
  • Options
    Hi mltgames,

    Thank you for taking the time to post your solution. I'm glad that is all sorted for you now.

    If you need anything else in future then get in touch.
    Customer Support | Redgate Software
Sign In or Register to comment.