Fixing & regenerating doesn't seem to fix the problem?

I am trying out SQL Data Generator. I ran it once and found some issues with the types that mapped to the columns, so I went and adjusted them accordingly & saved the project. (for example, Error converting data type varchar to numeric.) However, when I try to re-run the generate data after making the fix, it acts like there was no fix. I tried enabling verbose logging, but there is no useful information about what it is trying to put where. When I view the preview of data in the table that is erroring, everything looks correct.

Is this a known problem? If not, are there any other ways I can troubleshoot the issue?
Tagged:

Comments

  • Jessica RJessica R Posts: 970 Rose Gold 2
    Hi @rmcf ,

    We had a support ticket open for you and I'm just copying my reply here--please let us know if you're still running into issues!

    ---

    That is an odd problem that you're running into and I'm afraid I'm not immediately sure what is causing this. Can I just double check--what version of SQL Data Generator do you have installed? (Help>About)

    And would it be possible for you to create a scripts folder of your database so that we can try recreating the issue? (I unfortunately haven't been able to reproduce this so far). I can send over the steps to do this if so. If not, I'll think of other steps we can check/try--please let me know!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


Sign In or Register to comment.