What are the challenges you face when working across database platforms? Take the survey
Options

Active tab background color in SSMS 17 not changing

I have configured different colors for different Environments, however the background color of the active tab does not change, only the text color, and that makes it quite difficult to distinguish which tab is active.
This worked fine in SSMS 2016.
Please fix.
Tagged:

Comments

  • Options
    Jessica RJessica R Posts: 1,319 Rose Gold 4
    Thanks for your post!

    Can I please check what version of SQL Prompt you have installed (Help>About)?

    SQL Prompt should change the background color - can you kindly send a screenshot of what the active tab looks like for you?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • Options
    Thanks for getting back to me, however it seems that it has not resolved it self, and the background colors are changing normally again. I'm not sure what fixed it - the only thing I can think of is restarting, but I did that several times before posting the problem - but it's working now, so I'm happy :smile:
    By the way - I'm running SQL Promot 7.5.1.1000.
  • Options
    Jessica RJessica R Posts: 1,319 Rose Gold 4
    That''s great to hear, Kresten! :smile:

    I'm not sure what has resolved it either, but please let us know if you see the issue return!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • Options
    It just happened again. It seems to be correlated with SSMS having through the System.OutOfMemoryException.
  • Options
    Jessica RJessica R Posts: 1,319 Rose Gold 4
    Hi Kresten,

    Sorry to hear that!

    SSMS is a 32-bit process, so it is unfortunately limited to 2GB of memory, but there is a Large Address Aware tool available that can increase the max to 4GB, and this should hopefully prevent the issues you're seeing.

    You can download the Large Address Aware tool from here: https://www.techpowerup.com/forums/attachments/laa_2_0_4-zip.34392/
    • When you launch the tool, select ssms.exe as the executable​ - it will usually be located in a path like this - C:\Program Files (x86)\Microsoft SQL Server\xxx\Tools\Binn\ManagementStudio\ssms.exe (where xxx is your ssms version number)
    • ​Tick the "Check this box to enable the application to use more than 2GB of memory" checkbox
    • Click Save
    • Try using SQL Prompt again to see if the memory issues persist

    I hope that helps!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • Options
    Thanks for the suggestion - I'll have to give that a try! :smiley:
  • Options
    Jessica RJessica R Posts: 1,319 Rose Gold 4
    Hi Kresten,

    No problem, please do let us know if that helps!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • Options
    Jessica R wrote: »
    Hi Kresten,

    No problem, please do let us know if that helps!

    I use SSMS every day, and before I tried the "Large Address Aware tool" trick it would probably run out of memory once or twice a week - I have not had these issues since!
    Thanks again for the advice!
  • Options
    Jessica RJessica R Posts: 1,319 Rose Gold 4
    No problem, I'm so glad to hear that helped! :)

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


Sign In or Register to comment.