What are the challenges you face when working across database platforms? Take the survey
Options

Data differences not highlighted

Hi,

When I perform a data comparison, the differences are not highlighted in the row, as seen in this image:
https://drive.google.com/file/d/0B3SjrfAW6vB7WW9WLWFDVXA1VEk/view?usp=sharing

Both values have a light-blue cell colour, making it difficult to track the differences in the rows.

I tried the same comparison in version 11 and the difference was easily visible.

I am using SQL Data Compare version 12.2.1.4077.

Thank you

Comments

  • Options
    Hello, I'm sorry to hear that you hit this problem with SQL Data Compare.

    The issue with incorrect difference highlighting was fixed in SQL Data Compare V12.2.4, so upgrading to that version should resolve the problem.

    Please let us know if you are still having problems with this after upgrading.
  • Options
    Very good - 12.2.4 has fixed the issue.

    Many thanks.
  • Options
    I also am having this problem after updating yesterday to v12.2.1.4077. When I go to Help->Check for updates, it shows no updates available. Any ideas how to fix this?

    Thanks.
  • Options
    Hi Rich,

    At the moment we have only released this fix on our "Frequent Updates" channel, but the fix will be on our next default release too.

    If you are interested in getting frequent updates releases you can follow the instructions at https://documentation.red-gate.com/display/SC12/Turning+on+Frequent+Updates on how to set this up
    Matthew Chandler
    Software Developer on SQL Compare and SQL Data Compare
  • Options
    That worked, thanks
  • Options
    edited April 21, 2017 7:50PM
    I was having the same issue as noted above, but was hesitant to turn on Frequent Updates as I've been burned before. Nevertheless, I found there was really no other option since the issue seemed to be wholly that so long as there were *any* discrepancy in a column, the whole column's data was being highlighted as in the above's image. Same being true for any column with which *all* data was the same, it was showing "properly".

    I went from Version 12.2.1.4077 Professional to 12.3.1.43833 Professional (wasn't offered 12.2.4.x, so shouldn't there have at least been a "stable" release between the two "minor version", i.e. 12.2->12.3 changes?) and it would seem the issue is resolved as far as I can tell as well.

    I mostly posted elucidationally, but also in hopes the "fix" be pushed out to a stable release version sooner than later.
  • Options
    dstroutdstrout Posts: 2 New member
    I was having this issue as well. I turned on frequent updates and I'm on version 12.3.1.4383 Professional and the issue has been resolved.
  • Options
    JastelmerJastelmer Posts: 1
    edited April 27, 2017 6:26PM
    Hey I had similar issue, thats what brought me here. Updating to newest version fixed my problem
    Do not take life too seriously. You will never get out of it alive :)
Sign In or Register to comment.