What are the challenges you face when working across database platforms? Take the survey

Can't add System.Linq assembly

I wanted to look at the implementation of the System.Linq assembly but it wasn't showing me anything. I tried adding System.Linq from the GAC using File / Open Global Assembly Cache, but that didn't make any difference.

Next I closed the existing System.Linq assembly and it was removed from the Object Browser. Now I can't even add it back. I have tried adding from the GAC and using File / Open Assembly. I even tried dragging and dropping the file from Windows Explorer, but It doesn't add it back the the Object Browser.


  • Options
    Russell DRussell D Posts: 1,324 Diamond 5


    Can you provide an example of it not showing you anything?

    What happens if you add the dll back in from its location in the Framework folder (C:\Windows\Microsoft.NET\Framework\v4.0.30319)?

    Finally its not adding the System.Linq assembly right at the bottom of the list is it at all (rather than slotting it back in its alphabetical position)?

    Have you visited our Help Centre?
Sign In or Register to comment.