ASPX - profiler will not run due to 'incorrect format'

sramirezsramirez Posts: 4
edited March 14, 2017 11:57AM in ANTS Performance Profiler 9
I have a ASPX application that I am trying to run the performance profiler on but I get this error when launching ants

I am running the ANTS, Launch ANT performance profiler menu option in VS2015.

Could not load file or assembly 'file:///C:UserssramirezAppDataLocalTempTemporary ASP.NET Files
oot82292612874ac5cApp_global.asax.wsxkf9ke.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.

Can anyone tell me what I need to do?

When I run the application in debug mode in VS 2015 it runs fine.

I am running the 14 day free trial.

Comments

  • Thanks for your post and so sorry to hear you're running into an issue! To help us get a better idea of what's going wrong, can I please check:

    - Just to confirm, when you normally launch your application, it runs with IIS? When the profiler launches it, is it also using the ASP.NET - IIS option?
    - Does the application normally run as 32-bit or 64-bit? When the profiler launches the web application, is the process running with the correct bitness (you can check from Task Manager -- if it is running as 32-bit, it will either have an asterisk * or "(32-bit)" at the end of the name)
    - Does the error happen if you use the "Method level - only methods with source" profiling mode? Does it still happen if you use Sampling profiling mode?

    Thank you!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • It is running with IIS Express, both when it runs successfully (from VS2015) and when it runs ANTS.
    It is running with ANY PROCESSOR (32bit according to Task Manager

    I tried the sampling mode and got
    Could not load file or assembly 'file:///C:UserssramirezAppDataLocalTempTemporary ASP.NET Files
    oot82292612874ac5cApp_global.asax.6rta2xuq.dll' or one of its dependencies. An attempt was made to load a program with an incorrect format.

    Here is the DOS window that opens when I ran the sampling mode

    Copied template config file 'C:Program FilesIIS ExpressAppServerapplicationhost.config' to 'C:UserssramirezAppDataLocalTempiisexpressapplicationhost2017313175022745.config'
    Updated configuration file 'C:UserssramirezAppDataLocalTempiisexpressapplicationhost2017313175022745.config' with given cmd line info.
    Starting IIS Express ...
    Successfully registered URL "http://localhost:8013/"; for site "Development Web Site" application "/"
    Registration completed
    IIS Express is running.
    Enter 'Q' to stop IIS Express
    Request started: "GET" http://localhost:8013/
    Request ended: http://localhost:8013/ with HTTP status 500.0
    Request started: "GET" http://localhost:8013/favicon.ico
    Request ended: http://localhost:8013/favicon.ico with HTTP status 500.0
  • Thanks for those details!

    Just to confirm, does it run as 32-bit both when you run it normally from VS and when ANTS launches it?

    I just want to double check as the usual cause of this error is if the web application needs to run as 32-bit but the profiler launches it as 64-bit.

    If it normally runs as 32-bit, can you kindly open your solution, and click on ANTS>Launch ANTS Performance Profiler? Then when the settings for the profiling session come up, can you please click on "Show start URL options" (under the web application name/path textbox) and double check that the "Run application as 32-bit" option is enabled before starting the session?

    Please let me know if that helps or not!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • Thank you, running as 32bit solved my issue.
  • Thanks for the update, that's great to hear! :)

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


Sign In or Register to comment.