Upgrade FAIL: 262144 Error - NO HELP TO FIX!

PDinCAPDinCA Posts: 637 Silver 1
edited March 2, 2017 12:55PM in SQL Backup
Was 8.0. something.

Chose Update from the UI.

UI Installed - needs Server update (expected).

Copy step fails!

I went to the incredible UNHELPFUL page cited below. WHAT DO I NEED TO DO TO FIX IT!?

.: Server Component Installation - Failed
=========================================

Copying and running SQBServerSetup - Failed

Error running installer: exit code 262144
See http://www.red-gate.com/sqlbackup/install_errors for more information.



Starting SQL Backup Agent service - Pending

Operation pending.


Checking installed versions - Pending

Operation pending.


Checking SQLBackup extended stored procedures - Pending

Operation pending.


Verifying installation - Pending

Operation pending.


Updating SQL Server information - Pending

Operation pending.
Jesus Christ: Lunatic, liar or Lord?
Decide wisely...

Comments

  • Hi PDinCA,

    In this instance I would try to manually install the SQB Server components. You can do this following the bellow steps

    •On a machine that has the updated install of SQL Backup, there should be the following file: c:program files x86Red GateSQL Backupsqbserversetup.exe
    •copy the SQBServersetup.exe to the machine running SQL Server that is going to be backed up
    •Run SQBServerSetup.exe on the SQL Server instance and follow through the wizard

    Let me know if this doesn't work for you.
    Kind regards,
    Dan Bainbridge
    Product Support Engineer | Redgate Software
  • PDinCAPDinCA Posts: 637 Silver 1
    As posted to the Zendesk ticket, manual install was the first thing I tried. Installer was unable to access the local instance to determine if my login was a member of local admin group, which it has been from day 1 of the server's existence.

    Took the customary uninstall then reinstall sledgehammer approach to get it up and working again.

    This is the second failure of this kind when updating from 8.0.x to 8.4
    Jesus Christ: Lunatic, liar or Lord?
    Decide wisely...
  • Hi PDinCA,

    Apologies for the problems you are seeing. It looks like this error is related to the other one in that a backup was running. I will feed this back to the developers to include in any improvement work that is carried out.
    Kind regards,
    Dan Bainbridge
    Product Support Engineer | Redgate Software
Sign In or Register to comment.