SSMS 17RC2 Source Control 5.5 Error

nsundararajannsundararajan Posts: 35 Bronze 5
edited March 15, 2017 3:59PM in SQL Source Control
I've installed Source Control 5.5 but when I tried to open SSMS 17.0 getting the following error and source control didn't work

I've posted in Friends of Redgate Group with attachment.
Tagged:

Comments

  • Thanks for your post and sorry to hear you're running into an issue!

    It looks like the error you're getting is that "the 'SQLSourceControlPackage' did not load correctly", which is often caused by a bad install. Can you kindly uninstall SQL Source Control, and then reinstall from here: ftp://support.red-gate.com/patches/sqls ... 2.4725.exe?

    I hope that helps! If the problem remains though, can you please send us the error details from your activiylog.xml file?

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • Hello,
    I am receiving the same error.
    I have tried to uninstall Source Control and reinstall. It works the first time I use SSMS but then when I close and reopen SSMS I receive the error again.

    I also cannot open the SSMS "Connect" window when this is happening, so I can not use SSMS at all.
  • My SSMS 17.0 RC2 (I re-installed SSM17 RC2) was working fine until I install SQL Source 5.5.2.4725. Once I install I'm getting error message Cannot find one or more components. After installing the new SSMS 17.0 RC2 I first installed the latest SQLSearch it worked fine. But still SQL Source Control was not working. So I did downloaded using frequent updates and after install I got an error message saying launch visual studio. I have visual studio 2015 Enterprise. So I did then after that I'm getting the error message cannot find one or more components and it didn't work.
  • I've sent the Activity Log.xml and SQL Source Control log files as per request from Support. BTW the SSMS don't even work after the error message.
  • I've sent the Activity Log.xml and SQL Source Control log files as per request from Support. BTW the SSMS don't even work after the error message.

    I have the same issue as nsundararajan, I have to complete uninstall source control to continue use of SSMS, and to "check in" changes I have to reinstall source control, just to uninstall it again.
    Any update on a solution, or should I also submit my own ticket?
  • nsundararajannsundararajan Posts: 35 Bronze 5

    Still having problem. I'm using SSMS 17.0 RC3. According to MSFT SSMS 17 GA next month. Need help!!!!!

  • nsundararajannsundararajan Posts: 35 Bronze 5

    Jessica I'm still having issues, Please help me. I've heard the SSMS 17.0 is going to be released this month. I like to have SSMS 17.0 works with Source Control.

    Thanks,
    Nathan

  • Mike UMike U Posts: 315 Gold 1
    edited April 5, 2017 12:09PM
    One thing that has helped some users with similar problems has been to reset the window layout (from the Window menu, click on Reset Window Layout)
    Development Lead
    Redgate Software
  • Hi,
    I have an issue with Source Control 5.5.4.5524 and SSMS 17RC3. I get an errore message.

    4lw62sj9n4h3.png
  • I tried resetting the windows layout. Still didn't fix.
  • This is the error message I got when I did the Reset Window Layout

    An exception was encountered while constructing the content of this frame. This information is also logged in "C:\Users\xxxxxxx\AppData\Roaming\Microsoft\AppEnv\14.0\ActivityLog.xml".

    Exception details:
    System.Runtime.InteropServices.COMException (0x80004005): Error HRESULT E_FAIL has been returned from a call to a COM component.
    at Microsoft.VisualStudio.Shell.Interop.IVsShell5.LoadPackageWithContext(Guid& packageGuid, Int32 reason, Guid& context)
    at Microsoft.VisualStudio.Platform.WindowManagement.WindowFrame.GetPackage()
    at Microsoft.VisualStudio.Platform.WindowManagement.WindowFrame.ConstructContent()
  • The most recent default channel release of SQL Source Control, version 5.5.7, has fixed a bug that sometimes occurred if you had both SSMS 2016 and SSMS 17 installed. It would be worth updating to that version and seeing if it resolves the problem.

    If that doesn't fix the problem, could you post the relevant contents of the ActivityLog.xml, because that might help us diagnose it.
    Development Lead
    Redgate Software
  • TM123TM123 Posts: 2 New member
    This error happens when you have SQL Srouce Control tab open and you close SSMS. Then, the next time you start SSMS you will get this error. You won't get this error if you close the SQL Source Control tab before closing SSMS. If you get this error, then SSMS will be unable to connect to any database. This is very frustrating. Can you please actually correct this? Uninstalling and reinstalling the latest does not fix this issue. Disabling SQL Prompt Tab History also does not solve this problem. The only way to avoid the error is to close the tab for SLQ Source Control before exiting SSMS.
  • We may have a lead on this - for those of you experiencing this problem, do you have the object explorer docked to the right hand side of SSMS (or anywhere other than the default left hand side)?
    Development Lead
    Redgate Software
  • TM123TM123 Posts: 2 New member
    I can confirm that having the object explorer on the right side is what causes this error to happen. Moving it to the left will make the issue stop happening. However, that is not ideal. I prefer this interface to match Visual Studio with the explorer on the right. Can I ask again, when might we expect a resolve to what is clearly an simple thing to fix?
  • Hi @TM123

    Thanks for your post.

    There are developers working on this at the moment but we do not have a firm time frame in place yet for when this will be resolved.

    Kind regards
    Customer Support
    Redgate Software
  • Confirmed the SqlSourceControlPackage load error exists with SSMS 17.9.1 and SQL Source Control 7.0.11.8918.

    Docking Object Explorer to the default left-hand side still appears to be a valid workaround.
Sign In or Register to comment.