Database could not be detected as it is linked.

mlsomersmlsomers Posts: 9
edited February 20, 2017 4:50AM in SQL Source Control
My colleague has tried "Ready Roll" (that apparently will be included with Visual Studio 2017) on our shared database which is also linked to Sql Source Control. After he uninstalled Ready Roll, none of us (him nor the rest of our team) can alter any stored procedures or make changes to the database any more.

Management Studio just shows a blank error pane with this text:
Database could not be detected as it is linked. Make sure that the user has linked a database to source control

Some of us have tried unlinking and re-linking the database to Sql Source Control, but without success.

Any ideas on how to restore our ability to develop on the database again?


  • The same colleague was also testing ApexSQL Source Control on a different database (but on the same server).
    After he unlinked it from Apex, we were able to make changes again.
Sign In or Register to comment.