Error- SQL Source Control is disabled because it is selected

jsgrajujsgraju Posts: 2
edited February 11, 2017 1:03AM in SQL Source Control
Hello,
I installed trial version of redgate to see how I can use work with Git integration on SSMS.
I linked a database in one SSMS window.
When I try to open a stored procedure in another SSMS window , I get an error that - SQL Source Control is disabled because it is selected in another SSMS window. To access it here, deselect the database in the other window.
Question is - is this a bug or am I missing any setup ?
I should be able to work on a linked database in multiple SSMS windows. Advice!
Tagged:

Comments

  • Thanks for contacting us!

    This error makes sense, because if both windows were working on the same database then there would be potential conflicts between the two repository and database readers.

    However, you can enable Source Control in multiple SSMS windows on the "Setup" tab under "Global options"

    Do let me know if you have any questions or issues with that!

    Warmly,
    Andrew Pierce
    Technical Sales Engineer
    Redgate Software
  • i've tried to disconnect from all databases, and then attempt connect to source control but still get same message! please help!!
  • Jessica RJessica R Posts: 1,239 Rose Gold 4
    Hi @jimhocker00!

    This will occur if there are multiple instances of SSMS.exe running. If you open Task Manager and "Show processes from all users" (or go to the "Users" tab and expand each user), do you see any other SSMS.exe processes running?

    To manually allow multiple SSMS windows to run SQL Source Control though, you open the RedGate_SQLSourceControl_Engine_EngineOptions.xml file in %localappdata%\Red Gate\SQL Source Control 5\can and add and set the AllowMultipleSsms option to True as below:

    <?xml version="1.0" encoding="utf-8" standalone="yes"?>
    <!---->
    <EngineOptions version="3" type="EngineOptions">
    <AllowMultipleSsms>True</AllowMultipleSsms>
    </EngineOptions>

    Please let us know if that helps or not.

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • EdZEdZ Posts: 3 New member
    Another twist.  I had that message about SSC being disabled but the multiple SSMS windows option had already been turned on.  I found a second SSMS.exe process in task manager and ended that, but still no luck - same message.  So I turned off the option and restarted SSMS.  Then turned the option back on and restarted SSMS again and finally the message was gone.
  • Jessica RJessica R Posts: 1,239 Rose Gold 4
    Hi @EdZ!

    Can I check what version you're on?

    There was a known issue at some point where if you had multiple SSMS instances open, SQL Source Control would keep a lock on the last selected database even after the SSMS instance closed. This should be fixed as of version 7.0.9.8829 though.

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • EdZEdZ Posts: 3 New member
    We use version 7.0.41.9770, so it is newer than 7.0.9.
  • PHMPHM Posts: 1 New member
    Hello,

    I'm using version 7.2.4.418 with SSMS v17.9.1. I have no SSMS windows open yet its giving me the same error. 

    Allow SQL Source Control to open in multiple SSMS windows is also checked.
Sign In or Register to comment.