Compare of tables in different schemas fails - v12.1.0.3760

DejaSQLDejaSQL Posts: 2
edited February 3, 2017 1:07AM in SQL Data Compare
I have two tables in the same database that share the same name and structure, differing in the schema. I am able to successfully unmap the two tables and remap the one from the first schema to the other in the second schema, applying a filter along the way. The data comparison appears to run with no issue but when the comparison is complete the results indicate that a comparison was performed on the table on the left to itself -- not to the "second schema" table. The table that had been on the right now appears as unmapped at the bottom of the table list.

I can 'trick' it by creating a view on the second table, using the schema of the first table. Going thru the mapping/matching/filtering exercise then works. Is this the expected behavior? All the examples posted online show tables in the same schema but I haven't seen anything that explicitly says you can't compare across schemas.

In summary
-comparing dbo.Table1 to sys.Table1: set up allowed, results revert to comparing dbo.Table1 to dbo.Table1
-comparing dbo.Table1 to dbo.Table1_view (built on sys.Table1): set up allowed, results as expected
-running v12.1.0.3760[/list]


  • Just to recap for anyone reading this - we fixed this by going to Owner Mapping and mapping the schemas together, then going to table mapping and mapping the tables together.

    Andrew Pierce
    Technical Sales Engineer
    Redgate Software
  • cilantrocilantro Posts: 2 New member
    I'm running into this same issue with version, but Andrew's fix does not seem to work for me. Here are the details:
    I'm trying to compare that same table across two different schemas: TableA.Schema1 on server X versus TableA.Schema2 on server Y.
    I'm able to map the two schemas together in Owner Mapping, and then the tables automatically find each other in Table Mapping (I also tried unmapping them and mapping them back together manually, with the same result).
    When I run the comparison, it stops with this error: "Validation Failure. Object '[Schema1].[TableA]' does not exist. Conditional Fast Rowcount method requested without specifying an expected count. Fast method will be used."
  • cilantrocilantro Posts: 2 New member
    Update: I just realized that the error message I'm seeing is coming from the checksum comparison module. I unclicked that in Options, and now the comparison works.

    So this issue is reduced to: Checksum comparisons do not respect Owner Mapping.
  • Jessica RJessica R Posts: 1,319 Rose Gold 4
    Thanks for updating the post @cilantro! Checksum comparison does not compare mapped tables with different names and this is a known issue (logged as SDC-1874). So sorry for the inconvenience caused but I'm glad you've got things working now!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?

Sign In or Register to comment.