Error when linking to SVN

suhailalisuhailali Posts: 2
edited December 28, 2016 1:27PM in SQL Source Control
I get the following error when I link to source control:
"Errors or warnings occurred whilst loading the folderInformation from C:UserssaliAppDataLocalRed GateSQL Source Control 5Transientsuagwwi3r.fef"

I thought that maybe it was my computer so I tried it on another computer and it's giving me the same error. Any ideas on what I should do? I'm thinking of deleting the SVN directory in SVN and recreating it using red gate source control but I want that to be the last resort. I'm on the latest 5.3 version of SVN.


  • Jessica RJessica R Posts: 1,319 Rose Gold 4
    Hi suhailali, thanks for your post and so sorry to hear you're running into an issue with SQL Source Control!

    We have seen this error recently and the issue was that the RedGateDatabaseInfo.xml file in the transient directory for some reason was setting the "DatabaseVersion" value set to 0 -- can you kindly see if this is the case and set the value to the correct version if so? It should be set to the integer that represents the version of SQL Server. For example:

    13 for SQL Server 2016 (i.e. <DatabaseVersion>13</DatabaseVersion>)
    12 for SQL Server 2014
    11 for SQL Server 2012
    10 for SQL Server 2008 and 2008R2

    I hope that helps but please let us know if any issues persist!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?

  • Tiago_SilvaTiago_Silva Posts: 2 New member

    I am facing exactly the same problem. I confirm <DatabaseVersion> is set to 0 in xml file.
    I changed it manually but it sets to 0 again when I try to open 'Commit' tab.
    Please assist.

    Tiago Silva
  • Tiago_SilvaTiago_Silva Posts: 2 New member
    Hi, I have solved the problem upgrading RedGate SQL SourceControl to the latest version
Sign In or Register to comment.