Upgrade to 6.0.15.6357 Web Service stuck on port 8081

OrientalHeroOrientalHero Posts: 8 New member
edited December 16, 2016 8:56AM in SQL Monitor 6
As part of the upgrade to 6.0.15.6357, the SQL Monitor Web Service was accidentally left on port 8081 (the test worked).
Tried using the config change within RedGate.Response.UI.Server.Service.exe.config in C:Program FilesRed GateSQL MonitorWeb. This was changed from 8081 to 8080.
Web service was restarted, still on port 8081 and the config file says 8080.
Server was restarted, still on port 8081 and the config file says 8080.
Finally uninstalled the web service component and re-installed it (installer recognized that the base monitor service was still there and up to date so didn't re-install that).
As part of this install of the web service, paid more attention to the port test and it was indeed on 8081, but changed it to 8080 and test was good.
Completed installing and the webservice is still only using port 8081. (and the config file says 8080)
Did another restart of the server but the webservice is still only using port 8081

How do we definitively change the port being used by the web service?

Comments

  • Forgot to mention, was upgrading from SQLMonitor_6.0.5.exe
  • Cool, support (different area) told me the config file for the port is now located here...!
    You can change the port by editing the port bound in this file:
    C:ProgramDataRed GateSQL Monitorapplicationhost.config

    Changed the port (it was showing 8081 which was good) back to 8080 and restarted the Web Monitor service.
    Job done. Avoided having to redistribute the url with a different port, opening the firewalls etc.
Sign In or Register to comment.