Deployment script for Assembly

micke314micke314 Posts: 4 Bronze 1
edited November 3, 2016 3:44AM in SQL Compare
Currently evaluating SQL Compare (12.0.33.3389).
Found that the code generated for the assemblies does not work in the deployment script.
Deploying directly to the target db works fine, files generated in a target folder for the objects is also fine but the deployment script file is not.
The assembly base64 code in the script file have an extra space after that needs to be removed for each line.

I might be doing something wrong since I have only used the product for 5 minutes.

Comments

  • Hi,

    We released a fix for this particular issue in 12.0.34. This is currently available on our frequent updates channel which can switched on by following the guide here.

    Regards,
    David
    Software Engineer
    Redgate Software
  • brockweaverbrockweaver Posts: 4 New member
    I had this same issue -- pulled down latest (12.0.35.3485) and it fixed the problem.

    However, the assembly we deploy has its "Permission Set" = UNSAFE in the db References, yet the script is still created having "WITH PERMISSION_SET = SAFE".

    Easy enough to rectify after script is generated, just thought I'd bring it to your attention.

    Note I've only tried generating the script, not deploying directly to the db.
  • micke314micke314 Posts: 4 Bronze 1
    Thanks, worked just fine.
Sign In or Register to comment.