SQL Search does not display any databases

kaeldowdykaeldowdy Posts: 2
edited September 26, 2016 9:43AM in SQL Search
Hello,

I've used SQL Search 2 on several workstations in multiple environments, and it's always worked for me without a hitch. I'm working on a different system/environment now, and when I installed SQL Search, no databases are listed. I'm using SSMS 2016 v 13.0.15700.28 with SQL Search v 2.3.1.388 on Windows 7 Enterprise 64-bit attempting to connect to a SQL 2008 R2 instance, v 10.50.6220.0 (SP3).

I connect to the server via integrated authentication, but I have limited rights to just a single database on the server. Is this a permissions issue where my limited rights are somehow hindering SQL Search's ability to display the database I at least have rights to see? I'm a db_owner in that database for what it's worth.

I tried looking for an XML file or some other configuration file/option but no dice.

Thoughts?
Kael

EDIT: Here's a screenshot if that's helpful: https://imgur.com/B3WdkeO

Comments

  • Eddie DEddie D Posts: 1,699 Rose Gold 5
    Hi, thank you for your forum post.

    I suspect that this is security permissions related. There is no XML file or configuration file that can be set. Below are the permissions required, depending on version of SQL.

    For SQL Server 2005 dbo or Sys Admin permissions are normally required. Alternatively you can use the GRANT VIEW DEFINITION TO [{username}] which provides SQL Search with permission to retrieve the metadata without giving dbo access.
    For SQL Server 2008 and SQL Server 2012, it may be necessary to grant VIEW SERVER STATE to access information about encryption keys otherwise a 'User does not have permission to perform this action' message may prevent the display of candidates.

    I hope the above helps.

    Many thanks
    Eddie
    Eddie Davis
    Product Support Engineer
    Redgate Software Ltd
    Email: [email protected]
Sign In or Register to comment.