SQL Backup error: SQL Backup could not access [HKEY_LOCAL_M

SteveMSteveM Posts: 8
edited August 18, 2016 9:08AM in SQL Backup Previous Versions
Greetings all,

I have SQL Backup 7 deployed to roughly 10 servers in my environment. All should be writing their backups to a network share, and restoring from that same share.
    All 10 of my SQL Backup installations are using the same service account. This account has Full Control over the aforementioned network share. This account is in the local Administrators group on each server. This account is has been granted "Logon as a service" rights on each server. This account has been granted sysadmin privileges on each instance of SQL Server.

8 of my servers are running Windows 2008 R2, and various versions of SQL Server (2008 through 2014). These servers operate perfectly. Backups can be written to my network share, and restored from my network share with no problem.

2 of my servers are running Windows 2012 R2 (one server with SQL 2008 R2, the other with SQL 2012). Neither of them can write to my network share, nor can they restore from my network share.

Upon failure, both servers display the same error: "SQL Backup could not access [HKEY_LOCAL_MACHINESOFTWARERed GateSQL BackupBackupSettingsGlobal(LOCAL)] running as user [MYSERVICEACCOUNTNAME]."

Can anyone shed some light on what I'm possibly missing? I've granted elevated rights to every area I can think of that's touched by the service / service account.

Since this process works flawlessly on my 8 "older" servers, simple deductive reasoning leads me to believe that this is an issue between SQL Backup 7 and Windows 2012 R2. Assuming that's the case, how would I go about finding a resolution?

Many thanks,
Steve

Comments

  • peteypetey Posts: 2,358 New member
    Could you please open the Registry Editor (regedit) on the Windows Server 2012 R2 machines, navigate to the HKEY_LOCAL_MACHINESOFTWARERed GateSQL BackupBackupSettingsGlobal(LOCAL) node, and edit the permissions so that the Everyone group has full access to that node? Then try running a test backup e.g.
    EXEC master..sqlbackup '-sql "BACKUP DATABASE model TO DISK = [<AUTO>]"'
    
    Does that work? If it does, then try backing up to the network share.
    Peter Yeoh
    SQL Backup Consultant Developer
    Associate, Yohz Software
    Beyond compression - SQL Backup goodies under the hood, updated for version 8
  • Thanks so much for replying, while your exact suggestion didn't work it did put me on the path to resolving my issue.

    It appears that for whatever reason, I needed to explicitly add my service account as an individual user to the nodes in the Registry and granting Full Control, rather than just adding the account to the Administrators group which has Full Control by default.

    For anyone who might stumble upon this topic:
      Open RegEdit.exe HKEY_LOCAL_MACHINESOFTWARERed GateSQL BackupBackupSettingsGlobal(LOCAL) Right Click the folder with your instance name (in my case (LOCAL)) Select "Permissions" Click "Add" Select your service account. Tick off the Full Control checkbox

    Again, sincere thanks to Petey.
Sign In or Register to comment.