Competition: What’s your favorite Redgate tool? Enter now.

"A full-text index ... has already been created"

charmon79charmon79 Posts: 6
edited August 26, 2016 12:37PM in SQL Source Control
I've got a SQL Source Control repository for a database, and I am trying to create a new, empty copy of the database based on that SSC repository as follows:

1. Create new, empty database with no objects.
2. Link database to my SSC repository (working folder, dedicated development mode)
3. Get Latest
4. Apply changes

Several tables in this database have full-text indexes. I have set the comparison options not to use transactions for deployment.

While applying the changes to the target database, it gets to one of the tables which has FT indexes, and throws the error: "A full-text index for table or indexed view 'dbo.Foo' has already been created."

The script for the dbo.Foo table does not have duplicate CREATE FULLTEXT INDEX statements within it, and there is not a duplicate CREATE FULLTEXT INDEX for this table in any other script. So, this error seems to be a bug.

Has anyone else encountered this & know a workaround?

I'm on SQL Source Control 5.1.0.2572 standard.

Comments

  • Hello,

    Do you have SQL Compare installed? If so, would it be possible to compare your database to the new empty database and see if the deployment script runs? You will need to ensure "Don't use transactions in deployment scripts" is selected in the project options. This will help us to see if the problem is with SQL Compare or SQL Source Control.

    Kind Regards,

    Joel Adams
    Product Support Team
  • This works as expected with SQL Compare if I choose the database as the source. It correctly syncs all objects, including FT indexes, into the empty target database.

    However, if I choose Source Control as the source, I receive the same error in SQL Compare UI that I receive in the SQL Source Control UI.

    SQL Compare version: 11.6.3.1926 professional
Sign In or Register to comment.