Competition: What’s your favorite Redgate tool? Enter now.

There is already an object named '#partitions_indexes'

a.higginsa.higgins Posts: 78 Bronze 2
edited September 30, 2016 11:59AM in SQL Source Control
When trying to register a working base on an existing database, I receive the following error: "There is already an object named '#partitions_indexes' in the database."

I have several other databases on the same server linked to source control, and am able to find and check in changes on those databases with no problems.

I'm using Version 5.1.5.3100, within SSMS 2016, hitting a SQL Server 2014 database in 2012 compatibility mode (don't ask).

I recently installed SQL Source Control on a new laptop, and copied most of the contents of the "SQL Source Control 5" folder from my old APPDATA folder. I've tried unlinking and relinking this particular database from my TFS system with no change - every time I go to the 'Commit' tab, the process fails with the error mentioned above. I don't recall seeing this error from the old laptop, but it had been a while since I checked in this particular database.

Comments

  • a.higginsa.higgins Posts: 78 Bronze 2
    And, after updating to SQL Source Control 5.2.0.318, the issue goes away. I'd assume this was part of the fix "SOC-7874, SOC-7878: SQL Source Control will clean-up temporary tables used when registering a database."
  • I'm getting the same error when getting latest updates to a shared database. (Commits give the same error).
    Do I have to kick everyone off the database so it can delete #partitions_indexes and set single user?
Sign In or Register to comment.