Include row count in SQL view

Bart ReadBart Read Posts: 997 Silver 1
edited October 28, 2016 11:17AM in ANTS Performance Profiler 9
Hey,


Another thing that would be really helpful is including the row count for queries in the SQL view - I don't need the full data, but the row count gives a useful information of the amount of data returned.

Why not just go to the execution plan view and re-run the query, I hear you ask?

Because in the context of an integration test case where test data is created on the fly at the beginning, operated upon by the test, and then deleted at the end this is useless because the data no longer exists. Thus, some indication of whether or not data was returned would be *really* handy.

(For context: I'm debugging one of those joyous SNIReadSyncOverAsync SQL Native Interface issues that nobody seems to know anything about, but SNIReadSyncOverAsync is often implicated when large resultsets are being returned - thing is, in this case, I don't think they are. SQL Profiler is showing me that in most cases either 1 or 0 rows are returned but, since all queries seem snappy in here, I'm having trouble isolating what's adding the ~500ms SNIReadSyncOverAsync to anywhere between 30 and 70% of the queries, including identical queries which sometimes execute instantaneously and sometimes not.)


Thanks,
Bart Read
Principal Consultant
bartread.com Ltd

Comments

  • Jessica RJessica R Posts: 989 Rose Gold 2
    Thanks for the context behind this, Bart-- I've logged this request as well as PP-3944. :)

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • Hi Bart,

    Were you able to figure out the SNIReadSyncOverAsync ? Please let me know.

    Thanks.
  • GowthamkumarnGowthamkumarn Posts: 1 New member
    edited August 7, 2018 8:29AM
    Hi Bart,

    Any solutions for SNIReadSyncOverAsync ?

    Thanks.
  • Bart ReadBart Read Posts: 997 Silver 1
    Yes, although I wouldn't guarantee this as a universal answer.

    In our case in was due to a virtual NIC misconfiguration in one of our VMs, which was running on VMWare VSphere.

    To fix the problem we needed to disable receive side coalescing on the guest NIC. To do this you can run the following from an elevated Powershell prompt:

    Disable-NetAdapterRsc *

    As I say, this fixed the issue for all, and all our troublesome queries started running in around 1ms, but I wouldn't guarantee it will work for everyone.

    HTH.


    Bart
    Bart Read
    Principal Consultant
    bartread.com Ltd
Sign In or Register to comment.