SQL Search 2.2 uninstall corrupts SSMS

dhoelzendhoelzen Posts: 2
edited June 6, 2016 8:17AM in SQL Search
Hi,

I tried SQL Search 2.2.0.183 for a while, but decided I didn't need it. So I uninstalled it. Later, I tried to use SQL Server Management Studio to run a backup, but it wouldn't start. It threw this error: "The application was unable to start correctly (0xc000007b). Click OK to close the application."
I clicked on OK, then another dialog popup pops up saying "SQL Server Management Studio has stopped working. Windows can check online for a solution to the problem." Then it offers options to fix it - none work. Below that is the Problem Signature:
"
Problem signature:
Problem Event Name: APPCRASH
Application Name: Ssms.exe
Application Version: 2011.110.5058.0
Application Timestamp: 537406e3
Fault Module Name: ntdll.dll
Fault Module Version: 6.2.9200.21815
Fault Module Timestamp: 56eaff87
Exception Code: c000007b
Exception Offset: 00078f3a
OS Version: 6.2.9200.2.0.0.400.8
Locale ID: 1033
Additional Information 1: ac05
Additional Information 2: ac0507478d1c5bd693cfc4fe3987e900
Additional Information 3: ac05
Additional Information 4: ac0507478d1c5bd693cfc4fe3987e900
"
Since I had installed SQL Search on both our Live and Test servers, but hadn't uninstalled it from our Test server, I checked both servers installed programs lists from Control Panel and compared them. On the date of the uninstall, Microsoft SQL Server 2012 Setup (English) had its size changed from 172 MB to 39.9 MB, and its version changed from 11.2.5343.0 to 11.3.6020.0 . There were at least 3 more SS2012 components that had their installed date, size, and versions changed. How would I go about fixing this so I can use SSMS from that server again? Thanks,

Dave

Comments

  • Sergio RSergio R Posts: 600 Rose Gold 5
    Hi Dave,

    SQL Search is an SSMS add-in, installing it will not change SSMS core files or change the version number.
    Maybe coincidentally you installed an update at more or less the same time?

    Regarding your SSMS issue my advice would be either to try to repair the install or uninstall and reinstall it from scratch.

    Thank you,
    Sergio
    Product Support Engineer
    Redgate Software Ltd
    Please see our Help Center for detailed guides on how to use our tools
Sign In or Register to comment.