What are the challenges you face when working across database platforms? Take the survey
Options

Obfuscating Silverlight Xap - Duplicate xaml resource names

rilehuddrilehudd Posts: 3
edited June 15, 2016 11:31AM in SmartAssembly
Here is the full message that I'm getting when obfuscating a xap file:
The build process failed during the preparation of the resulting assembly.
System.InvalidOperationException : Duplicate xaml resource names not supported in Silverlight based assemblies.

I tracked this down to a /Themes/generic.xaml file. At first I thought this error was regarding an ID name (x:Name). But it turns out even an empty resource dictionary has this issue. The only solution I have found so far is to avoid using the /Themes/generic.xaml mechanism.

Is there anyway to allow different projects to get merged+obfuscated, but both define different /Themes/generic.xaml?

Comments

  • Options
    Russell DRussell D Posts: 1,324 Diamond 5
    Hi rilehudd,

    I'm afraid that you've encountered a bug, which we do not yet have a fix for; for your reference this is SA-1886. Unfortunately there also isn't an ideal workaround for this, however the earliest build this was seen in is version 6.9, so downgrading to an earlier version is an option (you can download version 6.7 or version 6.8; the reason I've provided links to both is that we think that this bug was introduced in 6.8, but it wasn't detected until 6.9, so you have access to both versions just in case), or otherwise you will have to give the resources different names.
    Have you visited our Help Centre?
  • Options
    Sorry for the extremely late reply.
    But we ended up just adding a non-theme xaml resource.

    Appreciate the quick response to my original post.

    How would I go about using the reference to check on the status of the issue?


    Thanks!
    -Riley
  • Options
    Glad you came up with a solution :).

    Currently our bug tracking system is internal only, the best way to get an update is just to fire an email to support@red-gate.com with the reference number asking for an update.

    I can tell you that, at present, this bug hasn't been fixed but is marked for Review.
    Have you visited our Help Centre?
Sign In or Register to comment.