What are the challenges you face when working across database platforms? Take the survey
Options

Sql Prompt doesn't recognize alias

gerger Posts: 2 New member
edited May 3, 2016 5:52AM in SQL Prompt
I'm attempting to write a SPROC, but SQL Prompt has gone from making it 100% easier to 100% more frustrating. I'm trying to write a simple SELECT statement, nothing too fancy, but SQL Prompt's suggestions have totally gone off the rails. I've got a table with an alias defined:

Alias.png

But when I start typing that alias no table suggestions appear at all:

Suggestions.png
(* Alias circled since the suggestion window hides it)

I've tried refreshing suggestions via CTRL+Shift+D, I've tried closing and reopening SSMS, I've tried uninstalling and reinstalling SQL Prompt, all to no avail. It has got to the point where turning off SQL Prompt now enhances my development experience instead of the opposite. Help!

Comments

  • Options
    Aaron LAaron L Posts: 596 New member
    Hi Ger,

    Which version of SQL Prompt are you currently using? If you're not on 7.2.1 could you try upgrading to see that helps.

    If you're still having problems on the latest version could you forward the script you're having issues with to me (aaron.law@red-gate.com) and I'll look into it for you.

    Thanks,
    Aaron.
Sign In or Register to comment.