What are the challenges you face when working across database platforms? Take the survey
Options

SQL Compare: Ignore Comment/Whitespace codependent

ToddHarryToddHarry Posts: 5
edited April 18, 2016 10:13AM in SQL Compare 11
Redgate:

I think I found a bug when I compare a View between two databases, and the only difference in them is the comments, SQL Compare shows the View in the "identical objects" group even when the "Comments" checkbox is unchecked in the Ignore section of the "Edit Project... -> Options". When I then also uncheck "White space", then it does begin working (i.e. the View appears in the "X objects that exist in both but are different" group after a Refresh). Strangely, the change is not detected with only one of these two options checked; it only works when both are unchecked. Lastly, when looking at the View in the preview window (regardless of which Options are enabled), the correct line number and changes are highlighted in orange every time... so the change is being detected when I inspect the View in SQL Compare.

Environment to repro:
1. (client: ) Windows 10 running SQL Compare Version 11.5.2.509 standard:
2. (both DB's:) Microsoft SQL Server 2012 (SP3) (KB3072779) - 11.0.6020.0 (X64) Oct 20 2015 15:36:27 Copyright (c) Microsoft Corporation - Developer Edition (64-bit) on Windows NT 6.1 <X64> (Build 7601: Service Pack 1) (Hypervisor)

Just thought I'd submit that and see if anyone can recreate it. Our team met and decided that having Comments and Whitespace both turned off makes sense for our environment, so we won't be directly impacted immediately by this bug (if it is a bug)... but if it was my product, I'd want to fix it. :) Contact me back if anyone at Redgate needs a code sample of the View we're using, or my SQL Compare settings file to recreate the issue.

Love your products, btw.
Thanks!

Todd M. Harry
180 Medical, Inc.
Sr. Software Developer

Comments

Sign In or Register to comment.