Profiling W3SVC - World Wide Web Publishing Service

davebryantdavebryant Posts: 2
edited April 4, 2016 11:48AM in ANTS Memory Profiler 8
Whenever I attempt to profile the W3SVC service the ANTS Memory Profiler Hangs on "Starting Service World Wide Web Publishing Service" and does not allow me to take memory snapshots.

The only thing in the logs is:
INFO RedGate.Profiler.Engine.Startup.Sessions.BaseSession - Starting service 'World Wide Web Publishing Service'

I've set the timeout to 360 seconds and still have the same result.

What do I have to do to allow ANTS to profile the W3SVC? Profiling IIS within redgate isn't an option because it appears to crash when IIS consumes 4GB of memory

Comments

  • Jessica RJessica R Posts: 1,209 Rose Gold 4
    Hi there,

    Thanks for your post! I believe we also have a support ticket open with you and I've copied my reply below.

    ---

    Thank you for contacting Redgate support!

    Regarding your query, I'm afraid it's not possible for ANTS to profile the W3SVC service. :/ The profiler cannot hook into an application until it loads the .NET framework. Since the W3SVC service itself does not use .NET code, and when it is launched by the profiler, it cannot properly start up the sites normally hosted in IIS, these child processes don't load .NET either (though if it could do this, I'm afraid the crashing would likely still occur since that child process would still reach 4GB of memory). The profiler will remain in a "starting service" state as it waits for the .NET framework to load.

    In order to profile the site, I'm afraid you will need to profile via the IIS option. Unfortunately though as you've experienced, the profiler can only create snapshots up to 4GB, else it becomes very unstable. If you haven't already, it may help to reduce any memory overhead from the profiler. Could you kindly try the following:

    - Turn on the "make snapshots faster by leaving out object values" option.
    - Disable" profile child processes", "track disposal of IDisposable objects", and "profile unmanaged memory"
    - Disable any unneeded performance counters

    Apologies as I realize this is not the answer you were hoping for! I hope that reducing the overhead may help--please let me know how you get on!

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


Sign In or Register to comment.