What are the challenges you face when working across database platforms? Take the survey
Options

Toggle comments short cuts not working

mohaaronmohaaron Posts: 46
edited May 3, 2016 3:28PM in SQL Prompt
SQL Prompt 7.1.0.300

I am trying to set the short cut for comment/uncomment and I can't get anything I set to work. Can anyone give me a clue how to set the short cut. When I do set it to something and then try and use the short cut nothing happens. It's sort of like SQL Prompt and SSMS are overriding each other making it not work at all.

Thanks!

Comments

  • Options
    Hello,

    Sorry for the issue you are having in SSMS with SQL Prompt. Do you know if intellisense is turned off or on on your machine?
    Allen LeVan
    Red Gate Software
    US Product Support
  • Options
    Do you mean the Enable Suggestions option?
  • Options
    Aaron LAaron L Posts: 596 New member
    Hi,

    Apologies, I don’t think intellisense would affect this.

    I just had a go at recreating this but everything appeared to be working fine for me. Could I check which version of SSMS are you using? Also, do you have any other addins installed?

    If you open it up in the menu do you have any other shortcuts listed, eg:
    TEkvtt2.png
  • Options
    Yes, thanks for the clarification. I changed my global short cut to be Ctrl-Shift-C. Even if I change it back to the default Ctrl-K, Ctrl-C it still does not work. The Red Gate SQL Suite is the only Add On I have installed. I'm using SSMS 2014.

    Thanks for the help.
  • Options
    OK, sorry. I think I figured it out. I finally changed the short cut for SQL Query Editor and Comment selection now works with my Ctrl-Shift+C. Thank you for the time.
Sign In or Register to comment.