What are the challenges you face when working across database platforms? Take the survey
Options

SmartAssembly has stopped working

puffinpuffin Posts: 4
edited October 13, 2015 4:41AM in SmartAssembly
Yesterday, I installed and licensed SmartAssembly Developer on my workstation. It worked fine, obfuscated assemblies correctly - no issues.

Today I was writing some PowerShell to try and automate the obfuscation of our project and found that SmartAssembly no longer starts up.

Instead, attempting to run smartassembly.exe results in "The type initializer for ". " threw and exception" and trying to build using smartassembly.com results in:

SmartAssembly v6.10.0.218
Copyright © Red Gate Software 2005-2015

System.TypeInitializationException : The type initializer for '?.☺' threw an exception.


I have tried fully uninstalling SmartAssembly and reinstalling, but the issue is still occurring.

Any thoughts?

Comments

  • Options
    Hi puffin,

    This has been logged as a ticket (#51869), and I'll update this thread with anything useful we find.
    Have you visited our Help Centre?
  • Options
    In the interest of helping others who may come across this thread when they have the same problem, my issue was caused by a problem with the Microsoft Access 64-bit Driver.

    I uninstalled that and SmartAssembly, then did a clean reinstall and it all started working again.

    My thanks to RedGate for their excellent email support that resolved this issue.
Sign In or Register to comment.