Disable actions list

irisoftirisoft Posts: 11
edited September 7, 2015 3:27AM in SQL Prompt
Hi.

Is there a way to disable actions list?
The ideea of actions list is good, but it messes with other basic editing functionalities. It uses the Ctrl key to show a popup that steals focus, so Ctrl+click followed by typing goes to the popup instead of the query window. Also sometimes it gets weird with Ctrl+C and Ctrl+V and it is annoying.

Thank you.

Comments

  • Hi

    We can reproduce the Ctrl + click issue so we’ll start looking into fix.

    We haven’t seen the Ctrl+C, Ctrl+V weirdness you mentioned. Could explain this a bit more?

    If you want to turn off the popup, you can by edit the xml file under %localappdata%Red GateSQL Prompt 7RedGate_SQLPrompt_CommonUI_Options_UIOptions.xml and setting <EnableSurroundWithPopup> to False.

    Thanks
    Ali
  • Hi

    We think we've got a fix for this issue in this private build, please could you give it a try and let us know how you get on.

    Thanks
    Ali
  • Hi

    I can confirm that Ctrl + click issue is solved. Good work.
    The other thing, with Ctrl+C Ctrl+V, was probably related to the first issue, I don't really remember what was the problem. But now I tested a lot of combinations and it works fine.
    With the new build I noticed that long click no longer shows the popup. This is a good thing for when you want to avoid the popup. Keep it like this.

    Thank you.
Sign In or Register to comment.