SmartAssembly Not Compatible with Visual Studio 2015

brian.webbbrian.webb Posts: 8 Bronze 1
edited August 10, 2015 2:11PM in SmartAssembly
We're having a problem, stuck dead in the water. The new Roslyn compiler does not appear to be compatible with SmartAssembly. Compiling with Visual Studio 2015 or Visual Studio 2013 SP5 give us the following error when processed by SmartAssembly:
SmartAssembly has encountered an invalid symbol. The standard text appears after (you can find it on other threads).

If we compile in Visual Studio 2013 less than SP5 we do not get this error. We've tried .NET 4.5, 4.6, x86, x64, AnyCPU... Nothing works.

Please help, we're stuck. I've tried with version 6.9 and 6.7 and neither works.


  • We've figured this out for anyone that runs into this. One of our dependencies (Microsoft Office Interop) had "Embed Interop Types" set to True. When switching this to "False" all is good. Somehow SmartAssembly with the new Visual Studio 2015 compiler doesn't like this.
Sign In or Register to comment.