What are the challenges you face when working across database platforms? Take the survey
Options

Changing datapath reg entry on cluster

BokaBoka Posts: 32 Silver 3
edited October 29, 2008 3:02PM in SQL Backup Previous Versions
I've installed SQL Backup 5.3 on cluster. Everything was going smoothly but...
First thing I've met is that installation process make decision about datapath instead of the user!
Following instructions I found here I went to changing registry.
1. Take SQL Backup resource offline
2. Change reg entry (HKLM\Software\Red Gate\SQL Backup\BackupSettingsGlobal\<instance name>) with new value
3. Bring resource on line
Not a big deal but... when SQL Backup is online again I found registry entry reverted to old value.
What am I doing wrong?

Comments

  • Options
    Hi Boka,

    I apologise for the belated reply.

    The SQL Backup 5.3 Cluster Aware installation should allow you to set the location for the datapath.

    To change it, could you please take the SQL Backup resource offline.

    Make sure the SQL Backup Agent Service is stopped on all nodes.

    Change reg entry (HKLM\Software\Red Gate\SQL Backup\BackupSettingsGlobal\<instance name>) with new value on the Active Node.

    Start the SQL Backup Agent Service on the Active Node.

    Check that the change is correct and the data.sdf file is located in the new location.

    Bring the resource online.

    When you installed SQL Backup to your cluster, did you use the Cluster Aware Installation or do a manual Installation as per instructions on our website?

    Thanks,
    Matthew Flatt
    Redgate Foundry
  • Options
    BokaBoka Posts: 32 Silver 3
    Hi Matthew,

    Thanks for reply. That's exactly what I've done. If I start SQL Backup service nothing's happen. But in the moment when I bring SQL Backup cluster resource online windows revert reg value and recreate old path with new sdf file!

    Any other idea?
  • Options
    Hi Boka,

    I've had a mess around with it and found out the problem.

    After taking the SQL Backup Agent Resource offline you need to Select Properties and the Registry Replication tab.

    On this tab remove the Registry entry for BackupSettingsGlobal\<instance name> (You might want to copy this first to add it again later).

    Now set your Data location in the registry of both nodes.

    Go back to your Registry Replication and add the BackupSettingsGlobal\<instance name> entry.

    Now bring the resource online and the change should stick.

    I hope this helps.
    Matthew Flatt
    Redgate Foundry
  • Options
    BokaBoka Posts: 32 Silver 3
    Hi Matthew,

    That was a key to solve this problem. Thank you.
  • Options
    BokaBoka Posts: 32 Silver 3
    Hi Matthew,
    Unfortunately, this is solution just until failover. After move group to another node registry is changed. Is there a solution or this is a bug?
  • Options
    Hi,

    Did you change the registry on Both nodes and then add the Registry Replication in again?

    I've tested several times and the settings are holding.
    Matthew Flatt
    Redgate Foundry
  • Options
    BokaBoka Posts: 32 Silver 3
    Hi Matthew,
    First of all - installation is cluster aware.
    I have two nodes, active - pasive mode.
    I changed datapath following your instructions.
    When I move group from node A to node B than datapath is reverted to old value on node B and vice versa.
  • Options
    Hi Boka,

    The only other thing I can think of would be to uninstall and reinstall the Server Components. When installing you can specify the location of the data store.

    You can specify the Data location on Step 6 of the wizard when performing a cluster aware installation.

    Thanks,
    Matthew Flatt
    Redgate Foundry
Sign In or Register to comment.