Refactor pluggin deteriorated VS 2010

anders.isacsonanders.isacson Posts: 11 Bronze 1
Hi,
I installed an evaluation package from Red Gate for evaluating ANTS Memory Profiler. This package also installed .NET Reflector 8 including the VS plugin.

After that installation two deteriorations occurred:
1. Each time I open a WPF Window or Control while running my application in the build-in debugger the following error occurs when executing its InitializeComponent():
System.NullReferenceException occurred
HResult=-2147467261
Message=Object reference not set to an instance of an.
Source=System.Xaml
StackTrace:
vid MS.Internal.Xaml.Context.ObjectWriterContext.GetDestinationType()
InnerException:

I can continue running after this error message and everything works fine, but it is annoying since this will occur many times for Windows with several WPF controls in them.

2. The “User-unhandled” column in Debug/Exceptions has vanished.
I have uninstalled all Red Gate software and run a repair on Microsoft Visual Studio 2010 but the problem is still there!

Please help!

Comments

  • Jessica RJessica R Posts: 1,181 Rose Gold 4
    Hi Anders,

    Thanks for your post!

    When you install .NET Reflector it will automatically disable the "Debug just my code" option in Visual Studio - this allows the debugger to break on exceptions from system code and can also disable the “User-unhandled” column.

    To undo this change, you can go to Tools>Options>Debugging and under General, re-enable the "Enable just My Code" option. (If .NET Reflector was still installed, you'd also want to make sure to stop .NET Reflector from disabling it each time you restart VS by disabling the behavior from the .NET Reflector menu - .NET Reflector>Disable Just My Code on startup.)

    Apologies for any troubles caused and I hope the above info helps! Please let us know how you get on.

    Jessica Ramos | Product Support Engineer | Redgate Software

    Have you visited our Help Center?


  • anders.isacsonanders.isacson Posts: 11 Bronze 1
    Tank you very much.
    That solved the problem.

    Regards @nders
Sign In or Register to comment.