Sql Prompt Changing Shortcut keys

kathyjuddkathyjudd Posts: 3
edited April 29, 2015 12:34PM in SQL Prompt
Hi there,

I want to change the default shortcut keys for "Format SQL" to CTRL+i. But after restarting SQL Management it reverts back to the default shortcut keys. I've tried it on SQL Management 2012 and 2014. I'm able to change the shortcuts to SQL Management builtin features and those stick after restarting so it's something with SQL Prompt.

Can you tell how to fix this so that I can use my own shortcut key?

Eft6cEF.png

Comments

  • Hi Kathy,

    Unfortunately at the moment Prompt doesn't support setting the key bindings through the SSMS options.

    If you're on the latest version of Prompt (6.5) there is a work around which is to edit %localappdata%Red GateSQL Prompt 6RedGate_SQLPrompt_CommonUI_Options_UIOptions.xml and replace the <KeyboardBindingOverrides> node with:
    &lt;KeyboardBindingOverrides version="1" type="RedGate.SQLPrompt.CommonUI.Options.KeyboardBindingOverrides"&gt;
      &lt;Overrides type="Overrides" version="2"&gt;
        &lt;value version="1" type="Override"&gt;
          &lt;CommandName&gt;FormatSQL&lt;/CommandName&gt;
          &lt;Bindings&gt;SQL::Ctrl+I&lt;/Bindings&gt;
        &lt;/value&gt;
      &lt;/Overrides&gt;
    &lt;/KeyboardBindingOverrides&gt;
    
    This should set the format SQL command to Ctrl+I on the next startup, if not please let me know.

    Thanks,
    Aaron.
  • Yes, that worked. I'm so happy :-) That was very annoying.
Sign In or Register to comment.