Performance on Large DBs

JohnnymacJohnnymac Posts: 4
edited September 15, 2015 3:21AM in SQL Source Control Previous Versions
We're experiencing some productivity impacting performance issues with SSC on some of our larger databases where it can take 15+ minutes for it to complete the 'registering database' process on the commit changes tab. Has anyone else experienced this and if so how did you overcome it?

Comments

  • We are also having this same problem. Losing many, many hours waiting for the Get Latest and Commit Changes tab to update. We have not found any solutions yet.
  • We are currently evaluating the product and too are experiencing the same problem. It is making the product virtually unusable. Our typical database is about 3 GBs with about 1800 objects. I have tried using the filter rules to not include any static data and to only include triggers, functions, roles, users, schemas, tables, views, and stored procedures but it does not seem to affect the amount of time for "registering database" phase.

    Am i missing something? Like a setting or doing something in the wrong order? If anyone has any suggestions it would be greatly appreciated!
  • If you're not using encrypted objects, try setting DecryptPost2kEncryptedObjects to False in the comparison options. That ought to give some performance benefits.
    Software Engineer
    Redgate Software
  • I've had bad performance problems since I started using source control. For reference: ~50GB db, ~1700 tables, ~8000 stored procedures.
    What I ended up doing was setting up a separate machine on which I can let source control spin on the registering working base part for 20 minutes while I continue my work on my development computer.
  • I'm currently evaluating the product and haven't been able to successfully retrieve the schema, registering databases as it sits at 0%. We have a database in excess of 14000 tables. This is frustrating as the product was recommended to me. I cannot find any setting that allows me to load only the tables that I want loaded for the comparison. I can't find any setting as mentioned above in the comparison settings. I'm using 11.X
Sign In or Register to comment.