Profiling causes IIS to crash

kellystuardkellystuard Posts: 9
edited January 6, 2015 8:33AM in ANTS Performance Profiler 9
I'm sure this is something wrong with my machine. However, a re-install of both Visual Studio 2013 and ANTS Performance Profiler 9 have not made anything better. Everything is fine, unless I'm profiling. Any 4.* version produces the same result; adding references to MVC produces the same result. For some reason the 2.x branch (including 3.5) works as expected.

I've uploaded a reproduction video. It has all the reproduction steps, error messages, event logs, etc. It should be a very helpful start to figuring out what the issue is. I can give additional information, if requested.
Steps in video (6:05):
  1. New empty web project (4.5.1) (using IISExpress)
  2. Build
  3. Profile Performance (ANTS)
  4. Notice error right away
  5. Open Event Viewer to show all errors
  6. Run in VS to show no errors
  7. Show full IIS configuration
  8. Change web project to use full IIS
  9. Run in VS to show no errors
  10. Profile Performance (ANTS)
  11. Notice error right away
  12. Open Event Viewer to show new errors
  13. (Optional) Remain puzzled


  • Hi Kelly,

    Thanks very much for your post and very detailed video reproduction. Could you confirm whether you also get this when you are only profiling at method level (not line-level timings), please? If it does work with method-level timings only, you might have found a new variant of this known problem:

    Most of the development team are now away until the New Year, but I'll try to get some more information for you when they are back.

    Best wishes and Happy New Year,

    Dominic Smith,
    Project Manager,
  • Hi Kelly,

    I'm a member of the development team working on ANTS Performance Profiler.

    Thanks again for the video and reproduction steps. Unfortunately, we haven't had much luck reproducing the crash using the same configuration, so I'm a bit puzzled at what the problem could be. Just out of interest, did changing the profiling mode make any difference? I don't think it's likely to be a similar issue to the KB article as there isn't any code in the empty web app that could be at fault.

    It might be worth reinstalling the .net 4.5.1 development pack to see if that helps.

    Do you happen to have another machine with a similar configuration you could try this on to see if the problem is machine specific?


Sign In or Register to comment.