No search results

SimesSimes Posts: 3
edited January 20, 2016 12:59PM in SQL Search
I'm trying to search a database for text I know is present, but SQL Search doesn't find it. I've selected the database, all object types and inexact match. I've tried text that is a column name, a parameter to a stored procedure. and something that appears in the body of a stored procedure, but SQL Search finds none of them.

Yet if I choose a different database on the same server, SQL Search can find the text.

Why should that be? What can stop SQL Search from finding any text in one of the databases?

Oh, and I've also tried doing a re-index.

SQL Search version 2.0.1.36 - free edition

@version = "Microsoft SQL Server 2008 R2 (SP1) - 10.50.2500.0 (Intel X86) Jun 17 2011 00:57:23 Copyright (c) Microsoft Corporation Standard Edition on Windows NT 6.1 <X64> (Build 7601: Service Pack 1) (WOW64) (Hypervisor)"

Comments

  • me too. I have the same exact issue. I am able to find/search for schema values, but not actually text across multiple tables/columns.
  • Same issue for me as well.
  • Redgate don't seem to care. I will uninstall and spread the word.
  • PDinCAPDinCA Posts: 642 Silver 1
    Same problem.

    Searched-for text is in a literal within a CASE statement, but SS fails to see it.

    Target DB is 2012, SSMS 2014. Enterprise for both. Windows 8.1 Prop PC, if that's at all relevant.
    Jesus Christ: Lunatic, liar or Lord?
    Decide wisely...
  • This tool in its current condition is a poor joke

    Alex
  • Hi All,

    Sorry for the issue you are all having with SQL Search and also apologies for the delay in getting back to you. We had a technical glitch and a support ticket was not logged for this unanswered forum so sorry for that!

    Can you please let me know if this happens for this particular database? Any steps I could follow to reproduce the issue as I am having hard time reproducing?
    Anuradha Deshpande
    Product Support
    Redgate Software Ltd.
    E-mail: [email protected]
  • I have SQL server version 8.0.2305 and it doesn't show any results. Perhaps the server version is too old?
  • PDinCAPDinCA Posts: 642 Silver 1
    I hesitate to use SQL Search any more - it consistently blows SSMS 2014 out of the water.

    I've sent numerous {SA} blow-up reports over the last couple of months. No new release to fix the issue(s).

    No use of SS = no steps to reproduce.

    However, Anu, if you look at my post from this time last year, it clearly says what SS did not find - you could say you have "steps to reproduce".

    But, I took the risk and ran SS looking for the string, without quotes, "p/@f&quot;, which happens to be inside a CASE, as the name of the column, in single quotes. Zero results - it's used 6 times in an XML building multi-SELECT chunk of code.

    Silly me, running SS - I now have a completely unresponsive SSMS - oh, it's back after a 2-minute coffee break! This is why I don't use it unless I'm desperate - I'd rather, which I've taken to doing, have Windows Index the content of all my .sql files in my SVN working folders and search via Windows Explorer to get an initial hit-list. That's truly desperate!
    Jesus Christ: Lunatic, liar or Lord?
    Decide wisely...
Sign In or Register to comment.