Erratic Issues with Filters

SSMS2008R2, Windows 7, Dedicated database model.

Creating and editing filters has been hit or miss for us.

Lately we have been getting exceptions like this:

"The list of changes to commit was out of date, so the commit was refused by the server."
Commit failed: File 'C:Users[myappdatapath]LocalRed GateSQL Source Control 3WorkingBases4drekvat.mzlFilter.scpf' is out of date

I have restarted SSMS 2008R2 numerous times, refreshed the commit window, rebooted numerous times, reported as a bug (have not seen a ticket).

This happens also across multiple projects. We have to disable the filter file in order to complete checkins.

One thing I noticed in another project was a filter change I applied via an edit to a T-SQL script (that was created after a failed GET) did not get correctly refreshed in the diff panes. In other words, the panes showed a pending change in the commit window that was not an accurate reflection of the change that was made.

Comments

  • Hi Elliot,

    Have you tried unlinking and then relinking your database? If SQL Source Control's working folders have somehow ended up in an inconsistent state, this ought to fix it.

    Unless I know when you sent the error report, or which email address you entered when submitting the error report, it's going to be difficult to find. If you are able to recreate the error, send the report and let me know which email address it's under - drop an email to [email protected] with #32830 as the subject line so I can easily find it.

    Thanks.
    Software Engineer
    Redgate Software
  • Unfortunately unlinking and relinking the db resets my filter file. So I have to reapply filter settings across databases. This is not a very practical solution.
  • Hi Elliot,

    When you receive the error message, is it possible that another user has updated the filter settings in the repository and this is causing a conflict? If you close the error dialog box and do a "get latest", will it then let you commit afterwards?
    Software Engineer
    Redgate Software
  • This is a new filter for this user. I created a new filter, checked it in, then my subsequent edit cannot be saved. It never makes it to another user (we are introducing SQL SC to certain users and this is our 2nd user, with me being the first, so no other users have accessed this database). I have tried to modify the filter in other ways and check it in again and it still fails.

    The message is always the same.
    Commit failed: File 'C:UserserodriguezAppDataLocalRed GateSQL Source Control 3WorkingBases epzp0ib.1zlFilter.scpf' is out of date

    Other objects have checked in fine. I am going to delete it and try again, but this is not a practical solution for us if other users (we have up to 10 using SQL SC) modify these filters over the course of development.
  • Are there any filter settings in particular that seem to trigger this behaviour?

    I would like to try and recreate this behaviour if possible. If there are any files and filter settings that can reliably cause this problem, could I get a copy of them? Email them to [email protected] with #32830 as the subject line.

    Thanks.
    Software Engineer
    Redgate Software
  • I'll see what I can do. It might be a few days as I am in crunch time. Which would you like specifically?

    I just discovered this on a Role object that I modified. Coincidentally, it also has a filter that I cannot check in. So while at least two of our databases had filters I could not check in, this one has an additional item that cannot be checked in.

    Commit failed: File 'C:UserserodriguezAppDataLocalRed GateSQL Source Control 3WorkingBaseswfojqrz4.ht3SecurityUsersUSERNAMEHERE.sql' is out of date
  • So I believe I found out how to work around this.

    If I do an SVN GET using my SVN client, I believe the files that SQL SC is complaining about get "refreshed" and changes are displayed correctly. I'm continuing to test things out with this theory.
  • Our filters experience continue to be just terrible for us.

    I don't know what it is, but multiple users get these messages constantly:
    Commit failed: File 'C:UserserodriguezAppDataLocalRed GateSQL Source Control 3WorkingBaseslyxfcp55.tffFilter.scpf' is out of date

    We have tried disconnecting and reconnecting filters. It doesnt matter. Any time we try to update them they either fail completely or refuse to refresh and show/hide the things we actually request.
  • Hi Elliot,

    Which version of SQL Source Control are you using? If you're not using it already, try the latest version and see if it helps.
    Software Engineer
    Redgate Software
  • We have always updated when prompted to do so. It has not and does not make a difference.
  • Are you using the shared development model? If that's the case then you may have a problem as the shared model doesn't use the "get latest" feature.
    Software Engineer
    Redgate Software
  • As I stated when I first reported this issue almost 4 months ago, we are using the dedicated database model.

    It happens again and again. SQL Server 2008 R2.
  • Elliot,

    If you could send in an error report, it will help us to diagnose what is going on. Let me know what email address it is sent in under by putting it in an email to [email protected] with the email subject #36905

    Once we have seen this, we'll have a much better idea of where to proceed.

    Thanks.
    Software Engineer
    Redgate Software
  • To be frank, I have submitted numerous requests via the application.

    I have tried everything the tickets tell me to try, which has involved mostly "Disconnect and reconnect to SVN". But I have also closed and restarted SSMS, asked others to modify their filters (same behavior and results). I would love to know if anyone else has this issue with SVN.

    SVN Server 1.6.11
    SVN Client 1.8.11
    SQL SERVER 2008 R2
    SSMS 2008

    Even after updating to SQL SC 3.8 10 minutes ago, I still get:
    Commit failed: File 'C:UserserodriguezAppDataLocalRed GateSQL Source Control 3WorkingBasesd3uxzcqh.olzFilter.scpf' is out of date

    Now I'm hoping to explore the possibility that our version is not compatible in some way with SQL SC.
  • Elliot, I appreciate that you have already submitted some error reports, but unless I can pinpoint one as being from you I won't be able to find it among all the others that get sent in. I have spoken to the developers and they are happy to look into this but we really need an error report that is identifiable as being from you.

    The error report will give us the best shot of diagnosing the problem as it will provide us with the most information. If you could send just one more in, and let me know what email address you entered, it would really be appreciated.
    Software Engineer
    Redgate Software
  • I understand. I'll add it once the exception gets thrown again. Thanks.
Sign In or Register to comment.