Transaction Isolation Level Problem

GlycerineGlycerine Posts: 5 New member
edited October 31, 2014 11:46AM in SQL Compare 11
I just upgraded from 10.x of SQL Compare to 11.0.0.365. Previously, it would generate the following line properly:

SET TRANSACTION ISOLATION LEVEL SERIALIZABLE

Now, it is generating this line as:

SET TRANSACTION ISOLATION LEVEL

Note the space at the end after LEVEL, as if it is just leaving off the keyword. I've tried going into the application settings and changing it to something else, click OK, and rerunnning the compare, and then repeating the process to set it back to SERIALIZABLE, but it always comes up blank there. So if I were to click the Deploy button after it generates the scripts, it fails 100% of the time. The only way around it right now is to copy the script, add the word, and then run it manually. Is this a known issue, is there a fix to it that I can make, or am I stuck doing this until the next release?

Comments

  • I am also experiencing this while evaluating SQL Compare and SQL Source Control.

    In my instance, if I choose to Create a deployment script (after choosing which items were correctly identified for deployment), the transaction keyword level is not specified and I end up with errors like

    "Incorrect syntax near 'LEVEL'"

    And it only works if I manually add the type in the script window and execute it.
  • I have noticed the same problem. The first time I ran the new compare there was an error in one of the objects I was deploying, the missing SERIALIZABLE caused all the code to run (except the one with an error in) but NOT get rolled back!

    The only workaround I have found is to copy the code into management studio and add SERIALIZABLE before running the code.
  • Hi everyone,

    Thanks for posting on this thread. This is actually a known bug with reference SC-7563 (it should only occur with a source control source). We have a fix for it which should be released when 11.1 comes out (which should be in the next two weeks or so).

    Sorry about the inconvenience.

    Regards,
    Evan
    Evan Moss
    Product Support
    (866) 627-8107
  • GlycerineGlycerine Posts: 5 New member
    I have actually encountered this just comparing two straight up databases, no source control versions involved. They have source control revision numbers in the extended properties of the database that compare detects, but it is comparing what is currently in the database, not a version in source control (database is the option selected on data sources tab on the initial window that pops up doing the compare). And I just reproduced it.
  • Hi Glycerine,

    You're correct; I have also reproduced it with source controlled databases. I should have mentioned that in my last post.

    Thanks,
    Evan
    Evan Moss
    Product Support
    (866) 627-8107
Sign In or Register to comment.