What are the challenges you face when working across database platforms? Take the survey
Options

SQL Backup GUI doesn't close completely

waynephwayneph Posts: 29
edited September 12, 2008 7:05AM in SQL Backup Previous Versions
I have run into this issue a few times recently, and finally have decided to ask about it.

Occasionally when I am using the GUI to look at backup results, or to run an individual backup, the application doesn't close out properly. When I attempt to reopen it, I get the following message: "There is already a copy of SQL Backup running on this computer."

I double check the task bar, and "Applications" tab in the task manager, but don't see anything. Then when I go to the Processes tab, RedGate.SQLBackup.UI.exe is running, and actively using both CPU and Memory.

So far, I have just ended the process, which lets me reopen the application, but I'm curious as to what's happening. The process will stay there for at least an hour (so far that's all I've let it do) and it will take anywhere up to 50% of the CPU at a time. The memory changes aren't quite as drastic, but I have seen it go up and down, so I don't think it's just a final clean up procedure.

Any ideas on things I can look at to try and resolve this issue?
--wayne

Comments

  • Options
    Hi Wayne,

    Could you please try the following :

    Close the SQL backup GUI. Kill the process if necessary.

    Navigate to %:\Documents and Settings\<username>\Local Settings\Application Data\Red Gate\SQL Backup\Server Data

    Delete the contents.

    Open the SQL Backup GUI.

    Use the SQL Backup GUI as normal and see if you still encounter the problem when closing.

    Thanks,
    Matthew Flatt
    Redgate Foundry
Sign In or Register to comment.