What are the challenges you face when working across database platforms? Take the survey

Are there any known problems with 1:1 relations?

KlausEKlausE Posts: 6
Hi all,

I am currently evaluating SQL Data Generator and experiencing the following problem:

I have a 1:1 relation between the tables Users and Prospects.
The primary key of the users table (UserID) is migrated as a primary key to the prospects table. On the prospects table there is a column called FavListToken that stores a unique token.

I generate 500000 user records and then try to generate the appropriate 500000 prospects records. During the generation on the prospect records the data generator seems to stop responding. In the windows task manager I see that the process consumes about 40MB RAM and the CPU usage goes down to 0%. Cancel does not work anymore, I have to kill the process.

The project is configured to create a records in a single transaction. It works with a smaller set (5000 records) of records. It does not work for this set if I change the project to run 500 rows in a batch.

I am running the tool on a Vista PC to generate records on a remote SQL Server 2008.

Is this a limitation of the evaluation copy? Is it a bug? Do I need to change something in the configuration?

Any help or comment is appreciated.

Thanks in advance


  • Options
    Any news on this issue?
  • Options

    I think the issue you are experiencing is due to the way SQL Server handles committing the transaction. When in batch mode, we have multiple isolated transactions, because they only involve a small set of records you don't notice a delay when SQL commits the transaction.

    However, if you are not using batch mode, because of the amount of data your are processing, SQL Server takes longer to complete the transaction commit, which is why you are experiencing this. Out of interest, how long is the wait you are experiencing?

    Could I ask, why does batch mode not work for you?


  • Options

    I tried with batch mode before. This is actually the way I would prefer. It only executed the first batch on the 1:1 related table (Prospect) and then seemed to hang. I thought that it might reset some internal counter and then tries to insert the same rows again?! Then I tried to switch to transactional mode.
Sign In or Register to comment.